Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Scala 2.10.1 support

  • Loading branch information...
commit 09c4a8b15f33435efe1551adc43fa7c64ef64df7 1 parent 0dc49fb
@rozza rozza authored
Showing with 5 additions and 7 deletions.
  1. +4 −6 project/CasbahBuild.scala
  2. +1 −1  sbt
View
10 project/CasbahBuild.scala
@@ -10,8 +10,8 @@ object CasbahBuild extends Build {
organization := "org.mongodb",
organizationHomepage := Some(url("http://www.mongodb.org")),
version := "2.5.1-SNAPSHOT",
- scalaVersion := "2.10.0",
- crossScalaVersions := Seq("2.10.1-RC3", "2.10.0", "2.9.3", "2.9.2", "2.9.1")
+ scalaVersion := "2.10.1",
+ crossScalaVersions := Seq("2.10.1", "2.10.0", "2.9.3", "2.9.2", "2.9.1")
)
val allSourceDirectories = SettingKey[Seq[Seq[File]]]("all-source-directories")
@@ -39,7 +39,7 @@ object CasbahBuild extends Build {
autoCompilerPlugins := true,
libraryDependencies <<= (scalaVersion, libraryDependencies) { (sv, deps) =>
sv match {
- case "2.10.1-RC3" => deps
+ case "2.10.1" => deps
case "2.10.0" => deps
case _ => deps :+ compilerPlugin("org.scala-tools.sxr" % "sxr_2.9.0" % "0.2.7")
}
@@ -120,14 +120,12 @@ object Dependencies {
def scalatest(scalaVersion: String) =
(scalaVersion match {
- case "2.10.1-RC3" => "org.scalatest" % "scalatest_2.10" % "1.9.1"
case _ => "org.scalatest" %% "scalatest" % "1.9.1"
}) % "test"
def scalatime(scalaVersion: String) =
scalaVersion match {
case "2.9.3" => "com.github.nscala-time" % "nscala-time_2.9.2" % "0.2.0"
- case "2.10.1-RC3" => "com.github.nscala-time" % "nscala-time_2.10" % "0.2.0"
case _ => "com.github.nscala-time" %% "nscala-time" % "0.2.0"
}
@@ -137,7 +135,7 @@ object Dependencies {
case "2.9.2" => "org.specs2" %% "specs2" % "1.12.3"
case "2.9.3" => "org.specs2" % "specs2_2.9.2" % "1.12.3"
case "2.10.0" => "org.specs2" %% "specs2" % "1.14"
- case "2.10.1-RC3" => "org.specs2" % "specs2_2.10" % "1.14"
+ case "2.10.1" => "org.specs2" %% "specs2" % "1.14"
}) % "test"
}
View
2  sbt
@@ -114,7 +114,7 @@ declare -r sbt_opts_file=".sbtopts"
declare -r jvm_opts_file=".jvmopts"
declare -r latest_28="2.8.2"
declare -r latest_29="2.9.3"
-declare -r latest_210="2.10.0"
+declare -r latest_210="2.10.1"
declare -r script_path=$(get_script_path "$BASH_SOURCE")
declare -r script_dir="$(dirname $script_path)"
Please sign in to comment.
Something went wrong with that request. Please try again.