Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix for https://jira.mongodb.org/browse/SCALA-71 #50

Closed
wants to merge 1 commit into from

2 participants

@tvaughan77

Added a type=pom element for the example maven dependencies (since there are no JARs in the root of the groupId.artifactId scala-tools repo).

Also adding a stanza about scala 2.9.1 users

@tvaughan77 tvaughan77 Updating <dependency> examples for mvn configuration to use the <type…
…>pom</type> attribtue.

Adding a stanza about scala 2.9.1 users
48e5638
@rozza rozza referenced this pull request from a commit in rozza/casbah
@rozza rozza Maven Documentation fix a161cae
@rozza
Collaborator

Thanks for the code - this will be in 2.5.0

@rozza rozza closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 8, 2012
  1. @tvaughan77

    Updating <dependency> examples for mvn configuration to use the <type…

    tvaughan77 authored
    …>pom</type> attribtue.
    
    Adding a stanza about scala 2.9.1 users
This page is out of date. Refresh to see the latest.
Showing with 14 additions and 0 deletions.
  1. +14 −0 tutorial_src/source/setting_up.rst
View
14 tutorial_src/source/setting_up.rst
@@ -43,6 +43,7 @@ Scala 2.8.0 users::
<groupId>com.mongodb.casbah</groupId>
<artifactId>casbah_2.8.0</artifactId>
<version>2.1.5.0</version>
+ <type>pom</type>
<dependency>
Scala 2.8.1 users::
@@ -51,6 +52,7 @@ Scala 2.8.1 users::
<groupId>com.mongodb.casbah</groupId>
<artifactId>casbah_2.8.1</artifactId>
<version>2.1.5.0</version>
+ <type>pom</type>
<dependency>
Scala 2.9.0.1 users (Scala 2.9.0.1 contains `critical fixes against 2.9.0.final <http://www.scala-lang.org/node/9708>`; do not use 2.9.0.final)::
@@ -59,7 +61,19 @@ Scala 2.9.0.1 users (Scala 2.9.0.1 contains `critical fixes against 2.9.0.final
<groupId>com.mongodb.casbah</groupId>
<artifactId>casbah_2.9.0-1</artifactId>
<version>2.1.5.0</version>
+ <type>pom</type>
<dependency>
+
+
+Scala 2.9.1 users::
+
+ <dependency>
+ <groupId>com.mongodb.casbah</groupId>
+ <artifactId>casbah_2.9.1</artifactId>
+ <version>2.1.5-1</version>
+ <type>pom</type>
+ <dependency>
+
Setting Up Ivy (w/ Ant)
Something went wrong with that request. Please try again.