Skip to content

@alcaeus alcaeus released this Feb 4, 2020 · 184 commits to master since this release

The PHP team is happy to announce that version 1.6.0 of the MongoDB PHP library is now available. This library is a high-level abstraction for the mongodb extension.

Release Highlights

This release introduces classes and options to enable Client-Side Field Level Encryption. With this feature, sensitive data can be automatically encrypted (MongoDB Enterprise Edition only) or explicitly encrypted using the MongoDB\Driver\ClientEncryption API.

The MongoDB\Collection::updateOne, updateMany, replaceOne methods now support a hint option to specify the index that should be used for the query. The option is also supported for update operations in bulk writes. This option requires MongoDB 4.2 or later.

This release deprecates using a JavaScript instance with scope when calling MongoDB\Collection::mapReduce for the map, reduce, and finalize options. Use the scope option instead. The nonAtomic and sharded options for the $out Map-Reduce argument are also deprecated.

Please note that this is the last minor release series that is compatible with PHP 5. Support for PHP 5 will be dropped in the upcoming 1.7.0 release.

A complete list of resolved issues in this release may be found at:
https://jira.mongodb.org/secure/ReleaseNote.jspa?projectId=12483&version=24317

Documentation

Documentation for this library may be found at:
https://docs.mongodb.com/php-library/

Feedback

If you encounter any bugs or issues with this library, please report them via this form:
https://jira.mongodb.org/secure/CreateIssue.jspa?pid=12483&issuetype=1

Installation

This library may be installed or upgraded with:

composer require mongodb/mongodb^1.6.0

Installation instructions for the mongodb extension may be found in the PHP.net documentation.

Assets 2
You can’t perform that action at this time.