Skip to content
Browse files

minor: replace relative requires within .gemspec files to fix testing…

… in 1.9.x -- suggested by mlanett
  • Loading branch information...
1 parent a824533 commit 2c82762782150b0def7d86f6effd43b09c7f7cd8 @TylerBrock TylerBrock committed Feb 6, 2012
Showing with 7 additions and 3 deletions.
  1. +2 −1 bson.gemspec
  2. +2 −1 bson.java.gemspec
  3. +3 −1 bson_ext.gemspec
View
3 bson.gemspec
@@ -1,4 +1,5 @@
-require "./lib/bson"
+$:.unshift(File.join(File.dirname(__FILE__), 'lib'))
+require 'bson'
Gem::Specification.new do |s|
s.name = 'bson'
View
3 bson.java.gemspec
@@ -1,4 +1,5 @@
-require "./lib/bson"
+$:.unshift(File.join(File.dirname(__FILE__), 'lib'))
+require 'bson'
Gem::Specification.new do |s|
s.name = 'bson'
View
4 bson_ext.gemspec
@@ -1,4 +1,6 @@
-require './lib/bson'
+$:.unshift(File.join(File.dirname(__FILE__), 'lib'))
+require 'bson'
+
VERSION_HEADER = File.open(File.join(File.dirname(__FILE__), 'ext', 'cbson', 'version.h'), "r")
VERSION = VERSION_HEADER.read.scan(/VERSION "(\d[^"]+)"/)[0][0]
Gem::Specification.new do |s|

0 comments on commit 2c82762

Please sign in to comment.
Something went wrong with that request. Please try again.