Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

renamed mongo_bson to bson

  • Loading branch information...
commit 75091f5ae5600cd879534653375d2b3e0390a12e 1 parent 63b0dfc
Kyle Banker banker authored
10 mongo-bson.gemspec → bson.gemspec
View
@@ -1,9 +1,9 @@
-require "lib/mongo_bson"
+require "lib/bson"
Gem::Specification.new do |s|
- s.name = 'mongo_bson'
+ s.name = 'bson'
- s.version = Mongo::BSON::VERSION
+ s.version = '1.0'#Mongo::BSON::VERSION
s.platform = Gem::Platform::RUBY
s.summary = 'Ruby implementation of BSON'
@@ -11,8 +11,8 @@ Gem::Specification.new do |s|
s.require_paths = ['lib']
- s.files = ['Rakefile', 'mongo-bson.gemspec', 'LICENSE.txt']
- s.files += ['lib/mongo_bson.rb'] + Dir['lib/mongo_bson/**/*.rb']
+ s.files = ['Rakefile', 'bson.gemspec', 'LICENSE.txt']
+ s.files += ['lib/bson.rb'] + Dir['lib/bson/**/*.rb']
s.test_files = Dir['test/mongo_bson/*.rb']
s.has_rdoc = true
6 mongo-extensions.gemspec → bson_ext.gemspec
View
@@ -1,8 +1,8 @@
-require 'lib/mongo'
+require 'lib/bson'
VERSION_HEADER = File.open(File.join(File.dirname(__FILE__), 'ext', 'cbson', 'version.h'), "r")
VERSION = VERSION_HEADER.read.scan(/VERSION\s+"(\d+\.\d+(\.\d+\w*)?)\"/)[0][0]
Gem::Specification.new do |s|
- s.name = 'mongo_ext'
+ s.name = 'bson_ext'
s.version = VERSION
s.platform = Gem::Platform::RUBY
@@ -10,7 +10,7 @@ Gem::Specification.new do |s|
s.description = 'C extensions to accelerate the MongoDB Ruby driver. For more information about Mongo, see http://www.mongodb.org.'
s.require_paths = ['ext']
- s.files = ['Rakefile', 'mongo-extensions.gemspec']
+ s.files = ['Rakefile', 'bson_ext.gemspec']
s.files += Dir['ext/**/*.rb'] + Dir['ext/**/*.c'] + Dir['ext/**/*.h']
s.test_files = []
2  ext/cbson/version.h
View
@@ -14,4 +14,4 @@
* limitations under the License.
*/
-#define VERSION "0.19.2"
+#define VERSION "0.20"
2  lib/mongo.rb
View
@@ -1,7 +1,7 @@
$:.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
module Mongo
- VERSION = "0.19.2"
+ VERSION = "0.20"
end
module Mongo
Please sign in to comment.
Something went wrong with that request. Please try again.