Skip to content
Browse files

RUBY-135 Oops. Yajl compability mode doesn't support object_class

  • Loading branch information...
1 parent f8fa61d commit 8a646fbf00f08bd173a63231408057fe500854bf @banker banker committed
Showing with 4 additions and 3 deletions.
  1. +4 −3 bin/j2bson
View
7 bin/j2bson
@@ -29,10 +29,11 @@ require 'bson'
# Note that, at the moment, this will not properly round-trip
# in all cases from the output generated by b2json.
begin
-require 'yajl/json_gem' # broken with 'json/ext'
+require 'json/pure' # broken with 'json/ext'
rescue LoadError
- puts "This script requires yajl. Please install the following:"
- puts " gem install yajl"
+ puts "This script requires json/pure. Please install one of the following:"
+ puts " gem install json_pure"
+ puts " gem install json"
Process.exit
end

0 comments on commit 8a646fb

Please sign in to comment.
Something went wrong with that request. Please try again.