Permalink
Commits on Jan 6, 2011
  1. BUMP 1.2.rc2

    banker committed Jan 6, 2011
Commits on Jan 5, 2011
  1. BUMP 1.2.rc1

    banker committed Jan 5, 2011
  2. BUMP 1.2.rc0 and HISTORY

    banker committed Jan 5, 2011
  3. RUBY-204 Collection construct now has analogous API

    banker committed Jan 5, 2011
    to DB constructor (i.e., name comes first)
  4. Test for RUBY-188

    banker committed Jan 5, 2011
Commits on Jan 4, 2011
Commits on Jan 3, 2011
  1. minor: BSON constant fix

    banker committed Jan 3, 2011
  2. Better .gemspec.

    benburkert committed with banker Dec 30, 2010
    * Seperate gemspec for the java platform gem.
    * Don't include jruby.jar.
    * Don't include unnecessary files.
  3. Get rid of "implicit conversion 64-bit 32-bit" warnings

    eregon committed with banker Dec 30, 2010
    This resolves "warning: implicit conversion shortens 64-bit value into a 32-bit value"
    The problem is String/Array length is a long (so 64 bits on some platforms instead of 32) and the extension use int
    There are 2 solutions:
    * use long everywhere (but waste of memory, and hard to do)
    * cast into ints (but potential lost of data)
    I did the second, because all these cases are about String/Array lengths,
    and it is very unlikely to have a String/Array of more than 2 billions elements (that would mean at least 2GB in memory).
    
    The last cast might need to be reviewed (htonl((int)time(NULL))) because htonl want a 32-bit int, but time(NULL) will overflow with the year 2038 problem.
  4. minor: claification

    banker committed Jan 3, 2011
  5. minor: docs

    banker committed Jan 3, 2011
Commits on Dec 30, 2010
  1. minor: docs

    banker committed Dec 30, 2010
Commits on Dec 29, 2010
  1. 1.2.rc0 BUMP for development

    banker committed Dec 17, 2010
  2. fix declaration-after-statement warnings of ruby trunk

    eregon committed with banker Dec 28, 2010
    The commit ruby/ruby@bd0a9d2
    adds -Werror=declaration-after-statement. This may cause an error and make gem installation fail
    See http://www.ruby-forum.com/topic/714046
Commits on Dec 28, 2010