Permalink
Browse files

Move dev dependencies to Gemfile.

- This way we have a bit more control over the environment. For example
  ffi is currently not building on travis, but we actually dont need it
  there since guard wont be run.
  • Loading branch information...
1 parent 0372e53 commit 5fab4e0a4f694bbcb3376c24b3ab1ad806f7cc3c @durran durran committed Jul 10, 2012
Showing with 10 additions and 5 deletions.
  1. +10 −0 Gemfile
  2. +0 −5 mongoid.gemspec
View
10 Gemfile
@@ -8,3 +8,13 @@ platforms :mri_19 do
gem "debugger"
end
end
+
+group :test do
+ gem "mocha", "0.11"
+ gem "rspec", "~> 2.11"
+
+ unless ENV["CI"]
+ gem "guard", "1.2.1"
+ gem "guard-rspec", "~> 0.7"
+ end
+end
View
5 mongoid.gemspec
@@ -22,11 +22,6 @@ Gem::Specification.new do |s|
s.add_dependency("moped", ["~> 1.1.1"])
s.add_dependency("origin", ["~> 1.0.3"])
- s.add_development_dependency("mocha", ["= 0.11"])
- s.add_development_dependency("rspec", ["~> 2.10"])
- s.add_development_dependency("guard", ["= 1.2.1"])
- s.add_development_dependency("guard-rspec", ["~> 0.7"])
-
s.files = Dir.glob("lib/**/*") + %w(CHANGELOG.md LICENSE README.md Rakefile)
s.require_path = 'lib'
end

0 comments on commit 5fab4e0

Please sign in to comment.