Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Bumping mongo dependency ~> 1.7 and bumping to 2.5.0

  • Loading branch information...
commit 78941abcaf9363afd4dc9073078e2ede5c0f7a57 1 parent 609875e
@durran durran authored
View
7 CHANGELOG.md
@@ -3,6 +3,13 @@
For instructions on upgrading to newer versions, visit
[mongoid.org](http://mongoid.org/docs/upgrading.html).
+## 2.5.0
+
+### New Features
+
+* This is a release to support the 1.7.0 and higher Mongo and BSON gems and
+ resolves issues that kept the 2.4.x series locked below 1.6.2
+
## 2.4.13
### Resolved Issues
View
2  lib/mongoid/version.rb
@@ -1,4 +1,4 @@
# encoding: utf-8
module Mongoid #:nodoc
- VERSION = "2.4.12"
+ VERSION = "2.5.0"
end
View
4 mongoid.gemspec
@@ -19,9 +19,9 @@ Gem::Specification.new do |s|
s.add_dependency("activemodel", ["~> 3.1"])
s.add_dependency("tzinfo", ["~> 0.3.22"])
- s.add_dependency("mongo", ["<= 1.6.2"])
+ s.add_dependency("mongo", ["~> 1.7"])
- s.add_development_dependency("bson_ext", ["~> 1.3"])
+ s.add_development_dependency("bson_ext", ["~> 1.7"])
s.add_development_dependency("mocha", ["= 0.11"])
s.add_development_dependency("rspec", ["~> 2.10"])
s.add_development_dependency("guard-rspec", ["~> 0.7"])
View
4 spec/functional/mongoid/persistence_spec.rb
@@ -606,8 +606,8 @@
end
it 'raises an error with multiple save attempts' do
- expect { subject.save! }.should raise_error
- expect { subject.save! }.should raise_error
+ expect { subject.save! }.to raise_error
+ expect { subject.save! }.to raise_error
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.