Skip to content
Newer
Older
100644 35 lines (34 sloc) 1.31 KB
ec08319 @cheald Add JRuby to travis. Minor spec fixes for JRuby compatibility.
cheald authored
1 language: ruby
ee1c4b2 @jnunemaker Added rails 3.0-3.2 gemfiles for travis.
jnunemaker authored
2 gemfile:
a37dca9 @cheald Get MM building on Rails 4.0. Add Ruby 2.0 and Rails 4 to the Travis …
cheald authored
3 - gemfiles/rails3_0.gemfile
ee1c4b2 @jnunemaker Added rails 3.0-3.2 gemfiles for travis.
jnunemaker authored
4 - gemfiles/rails3_1.gemfile
ec08319 @cheald Add JRuby to travis. Minor spec fixes for JRuby compatibility.
cheald authored
5 - gemfiles/rails3_2.gemfile
a37dca9 @cheald Get MM building on Rails 4.0. Add Ruby 2.0 and Rails 4 to the Travis …
cheald authored
6 - gemfiles/rails4_0.gemfile
1d68a48 @jnunemaker Added initial travis config.
jnunemaker authored
7 rvm:
8 - 1.9.3
a37dca9 @cheald Get MM building on Rails 4.0. Add Ruby 2.0 and Rails 4 to the Travis …
cheald authored
9 - 2.0.0
54b2be3 @leifcr Update travis to test on 2.1.1
leifcr authored
10 - 2.1.1
1d68a48 @jnunemaker Added initial travis config.
jnunemaker authored
11 notifications:
12 email: false
13 bundler_args: --without development
ad20a8c @wpeterson Declare TravisCI mongo service dependency.
wpeterson authored
14 services: mongodb
a37dca9 @cheald Get MM building on Rails 4.0. Add Ruby 2.0 and Rails 4 to the Travis …
cheald authored
15 matrix:
ec08319 @cheald Add JRuby to travis. Minor spec fixes for JRuby compatibility.
cheald authored
16 include:
8692c8e @dpoineau Adding ruby 1.8.7 specific gem files to use specific version of i18n
dpoineau authored
17 - rvm: 1.8.7
18 gemfile: gemfiles/rails3_0_ruby_1_8_7.gemfile
19 - rvm: 1.8.7
20 gemfile: gemfiles/rails3_1_ruby_1_8_7.gemfile
21 - rvm: 1.8.7
22 gemfile: gemfiles/rails3_2_ruby_1_8_7.gemfile
ec08319 @cheald Add JRuby to travis. Minor spec fixes for JRuby compatibility.
cheald authored
23 - rvm: jruby-19mode
24 gemfile: gemfiles/rails3_0.gemfile
25 env: JRUBY_OPTS="--server -Xcompile.invokedynamic=false -J-XX:+TieredCompilation -J-XX:TieredStopAtLevel=1 -J-noverify -J-Xms512m -J-Xmx1024m"
26 - rvm: jruby-19mode
27 gemfile: gemfiles/rails3_1.gemfile
28 env: JRUBY_OPTS="--server -Xcompile.invokedynamic=false -J-XX:+TieredCompilation -J-XX:TieredStopAtLevel=1 -J-noverify -J-Xms512m -J-Xmx1024m"
29 - rvm: jruby-19mode
30 gemfile: gemfiles/rails3_2.gemfile
31 env: JRUBY_OPTS="--server -Xcompile.invokedynamic=false -J-XX:+TieredCompilation -J-XX:TieredStopAtLevel=1 -J-noverify -J-Xms512m -J-Xmx1024m"
32 - rvm: jruby-19mode
33 gemfile: gemfiles/rails4_0.gemfile
34 env: JRUBY_OPTS="--server -Xcompile.invokedynamic=false -J-XX:+TieredCompilation -J-XX:TieredStopAtLevel=1 -J-noverify -J-Xms512m -J-Xmx1024m"
Something went wrong with that request. Please try again.