Permalink
Browse files

Use bundler for development dependencies

  • Loading branch information...
1 parent e3b4708 commit c297a3215aa4a2aa3525ae3a7acbe72b96561e32 @bkeepers bkeepers committed Sep 12, 2010
Showing with 57 additions and 10 deletions.
  1. +2 −0 .bundle/config
  2. +2 −0 Gemfile
  3. +49 −0 Gemfile.lock
  4. +1 −0 Rakefile
  5. +2 −0 mongo_mapper.gemspec
  6. +1 −10 test/test_helper.rb
View
@@ -0,0 +1,2 @@
+---
+BUNDLE_DISABLE_SHARED_GEMS: "1"
@bdimcheff

bdimcheff Nov 14, 2010

Is this .bundle/config supposed to be checked in? .bundle is in gitignore, but maybe you need this disable shared gems thing?

@bkeepers

bkeepers Nov 16, 2010

Contributor

Good question. What's everyone else doing?

@bdimcheff

bdimcheff Nov 16, 2010

AFAIK you're supposed to ignore everything in .bundle, since it'll get regenerated by the bundle command anyways

View
@@ -0,0 +1,2 @@
+source 'http://rubygems.org'
+gemspec
View
@@ -0,0 +1,49 @@
+PATH
+ remote: .
+ specs:
+ mongo_mapper (0.8.4)
+ activemodel (~> 3.0.0)
+ activesupport (~> 3.0.0)
+ plucky (~> 0.3.5)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ activemodel (3.0.0)
+ activesupport (= 3.0.0)
+ builder (~> 2.1.2)
+ i18n (~> 0.4.1)
+ activesupport (3.0.0)
+ bson (1.0.7)
+ builder (2.1.2)
+ i18n (0.4.1)
+ jnunemaker-matchy (0.4.0)
+ json (1.4.6)
+ log_buddy (0.5.0)
+ mocha (0.9.8)
+ rake
+ mongo (1.0.8)
+ bson (>= 1.0.5)
+ plucky (0.3.5)
+ mongo (~> 1.0.8)
+ rake (0.8.7)
+ shoulda (2.11.3)
+ timecop (0.3.5)
+ tzinfo (0.3.23)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ activemodel (~> 3.0.0)
+ activesupport (~> 3.0.0)
+ jnunemaker-matchy (~> 0.4.0)
+ json
+ log_buddy
+ mocha (~> 0.9.8)
+ mongo_mapper!
+ plucky (~> 0.3.5)
+ rake
+ shoulda (~> 2.11)
+ timecop (~> 0.3.1)
+ tzinfo
View
@@ -1,4 +1,5 @@
require 'rubygems'
+require 'bundler/setup'
require 'rake'
require 'rake/testtask'
require File.expand_path('../lib/mongo_mapper/version', __FILE__)
View
@@ -18,6 +18,8 @@ Gem::Specification.new do |s|
s.add_dependency 'activesupport', '~> 3.0.0'
s.add_dependency 'plucky', '~> 0.3.5'
+ s.add_development_dependency 'rake'
+ s.add_development_dependency 'tzinfo'
s.add_development_dependency 'json'
s.add_development_dependency 'log_buddy'
s.add_development_dependency 'jnunemaker-matchy', '~> 0.4.0'
View
@@ -1,24 +1,17 @@
require 'rubygems'
-gem 'activesupport', ENV['ACTIVE_SUPPORT_VERSION']
-gem 'json'
-gem 'jnunemaker-matchy', '~> 0.4.0'
-gem 'shoulda', '~> 2.11'
-gem 'timecop', '~> 0.3.5'
-gem 'mocha', '~> 0.9.8'
+require 'bundler/setup'
$:.unshift File.expand_path(File.dirname(__FILE__) + '/../lib')
require 'mongo_mapper'
require 'fileutils'
require 'ostruct'
-require 'active_support/version'
require 'json'
require 'log_buddy'
require 'matchy'
require 'shoulda'
require 'timecop'
require 'mocha'
-require 'ruby-debug'
class Test::Unit::TestCase
def Doc(name='Class', &block)
@@ -102,5 +95,3 @@ def drop_indexes(klass)
MongoMapper.connection = Mongo::Connection.new('127.0.0.1', 27017, :logger => logger)
MongoMapper.database = "mm-test-#{RUBY_VERSION.gsub('.', '-')}"
MongoMapper.database.collections.each { |c| c.drop_indexes }
-
-puts "\n--- Active Support Version: #{ActiveSupport::VERSION::STRING} ---\n"

0 comments on commit c297a32

Please sign in to comment.