Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updating Gemfile to allow running the tests with rubinius.

  • Loading branch information...
commit e1ceedd5048cc235ddb83edb34e91994b29a2905 1 parent c86b4e7
@gaffneyc gaffneyc authored bkeepers committed
Showing with 10 additions and 14 deletions.
  1. +1 −0  .gitignore
  2. +7 −6 Gemfile
  3. +2 −8 test/test_helper.rb
View
1  .gitignore
@@ -11,3 +11,4 @@ log
.yardoc
doc
.bundle
+*.rbc
View
13 Gemfile
@@ -3,18 +3,19 @@ gemspec
group(:development) do
gem 'bson_ext', '~> 1.3.0'
- gem 'SystemTimer', :platform => :ruby_18
- gem 'ruby-debug', :platform => :ruby_18
- gem 'ruby-debug19', :platform => :ruby_19, :require => 'ruby-debug'
+ gem 'SystemTimer', :platform => :ruby_18
+
+ gem 'ruby-debug', :platform => :mri_18
+ gem 'ruby-debug19', :platform => :mri_19, :require => 'ruby-debug'
+ gem 'perftools.rb', :platform => :mri, :require => 'perftools'
- gem 'perftools.rb', :require => 'perftools'
gem 'rake'
gem 'tzinfo'
gem 'json'
gem 'log_buddy'
- gem 'jnunemaker-matchy', '~> 0.4.0'
+ gem 'jnunemaker-matchy', '~> 0.4.0', :require => 'matchy'
gem 'shoulda', '~> 2.11'
gem 'timecop', '~> 0.3.1'
gem 'mocha', '~> 0.9.8'
gem 'rack-test'
-end
View
10 test/test_helper.rb
@@ -1,18 +1,12 @@
require 'rubygems'
require 'bundler/setup'
-$:.unshift File.expand_path(File.dirname(__FILE__) + '/../lib')
+$:.unshift File.expand_path('../../lib', __FILE__)
require 'mongo_mapper'
require 'fileutils'
require 'ostruct'
-require 'json'
-require 'log_buddy'
-require 'matchy'
-require 'shoulda'
-require 'timecop'
-require 'mocha'
-require 'ruby-debug'
+Bundler.require(:development)
class Test::Unit::TestCase
def Doc(name='Class', &block)
Please sign in to comment.
Something went wrong with that request. Please try again.