New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tls + fastcgi crashed #226

Closed
J-Siu opened this Issue Dec 13, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@J-Siu

J-Siu commented Dec 13, 2015

http to static and fastcgi work
https to static work
https to fastcgi crashed

/monkey/build$ ./monkey 
Monkey HTTP Server v1.7.0
Built : Dec 12 2015 22:38:06 (/usr/bin/cc 5.2.1)
Home  : http://monkey-project.com
[+] Process ID is 23093
[+] Server listening on 0.0.0.0:2001
[+] Server listening on 0.0.0.0:2443
[+] 4 threads, may handle up to 1024 client connections
[+] Loaded Plugins: liana fastcgi tls 
[+] Linux Features: TCP_FASTOPEN SO_REUSEPORT 
[2015/12/12 22:44:40] [   Info] HTTP Server started
IOV_IDX=62 > IO_SIZE=61

[index=0 len=16]
'[end=16]

[index=1 len=10]
'
 '[end=10]

[index=2 len=15]
'SERVER_SOFTWARE'[end=15]

[index=3 len=12]
'Monkey/1.7.0'[end=12]

[index=4 len=10]
'
    '[end=10]

[index=5 len=11]
'SERVER_NAME'[end=11]

[index=6 len=9]
'127.0.0.1'[end=9]

[index=7 len=10]
'[end=10]

[index=8 len=13]
'DOCUMENT_ROOT'[end=13]

[index=9 len=25]
'/home/john/monkey/htdocs/'[end=25]

[index=10 len=10]
'
'[end=10]

[index=11 len=11]
'SERVER_ADDR'[end=11]

[index=12 len=13]
'192.168.0.114'[end=13]

[index=13 len=10]
'
 '[end=10]

[index=14 len=11]
'SERVER_PORT'[end=11]

[index=15 len=4]
'2443'[end=4]

[index=16 len=10]
'
'[end=10]

[index=17 len=11]
'REMOTE_ADDR'[end=11]

[index=18 len=13]
'192.168.0.100'[end=13]

[index=19 len=10]
'
 '[end=10]

[index=20 len=11]
'REMOTE_PORT'[end=11]

[index=21 len=5]
'53392'[end=5]

[index=22 len=10]
'4#'[end=10]

[index=23 len=15]
'SCRIPT_FILENAME'[end=15]

[index=24 len=35]
'/home/john/monkey/htdocs//hello.php'[end=35]

[index=25 len=10]
'

'[end=10]

[index=26 len=11]
'SCRIPT_NAME'[end=11]

[index=27 len=10]
'/hello.php'[end=10]

[index=28 len=10]
''[end=10]

[index=29 len=14]
'REQUEST_METHOD'[end=14]

[index=30 len=3]
'GET'[end=3]

[index=31 len=10]
'

'[end=10]

[index=32 len=11]
'REQUEST_URI'[end=11]

[index=33 len=10]
'/hello.php'[end=10]

[index=34 len=10]
'
 '[end=10]

[index=35 len=12]
'QUERY_STRING'[end=12]

[index=36 len=7]
't-Encod'[end=7]

[index=37 len=10]
'   '[end=10]

[index=38 len=9]
'HTTP_HOST'[end=9]

[index=39 len=6]
'u64s04'[end=6]

[index=40 len=10]
'[end=10]

[index=41 len=20]
'HTTP_ACCEPT_ENCODING'[end=20]

[index=42 len=13]
'gzip, deflate'[end=13]

[index=43 len=10]
'L
  ?'[end=10]

[index=44 len=11]
'HTTP_ACCEPT'[end=11]

[index=45 len=63]
'text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8'[end=63]

[index=46 len=10]
'?t'[end=10]

[index=47 len=15]
'HTTP_USER_AGENT'[end=15]

[index=48 len=116]
'Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_2) AppleWebKit/601.3.9 (KHTML, like Gecko) Version/9.0.2 Safari/601.3.9'[end=116]

[index=49 len=10]
'[end=10]

[index=50 len=20]
'HTTP_ACCEPT_LANGUAGE'[end=20]

[index=51 len=5]
'en-us'[end=5]

[index=52 len=10]
'
'[end=10]

[index=53 len=8]
'HTTP_DNT'[end=8]

[index=54 len=1]
'1'[end=1]

[index=55 len=10]
'
[end=10]

[index=56 len=15]
'HTTP_CONNECTION'[end=15]

[index=57 len=10]
'keep-alive'[end=10]

[index=58 len=8]
''[end=8]

[index=59 len=8]
''[end=8]

[index=60 len=16]
'[end=16]

[index=61 len=10]
'
 '[end=10]
[2015/12/12 22:45:45] [  BUG !] Bug found in mk_iov_add() at /home/john/monkey/mk_core/include/mk_core/mk_iov.h:130
Aborted (core dumped)

edsiper added a commit that referenced this issue Dec 14, 2015

Plugins: FastCGI: use raw network handler when talking to the fastcgi…
… server (Fix #226)

Signed-off-by: Eduardo Silva <eduardo@monkey.io>

@edsiper edsiper closed this in 4abfde6 Dec 14, 2015

@edsiper

This comment has been minimized.

Show comment
Hide comment
@edsiper

edsiper Dec 14, 2015

Member

thanks for the report.

The problem was that the fastcgi plugin was using the tls network API to write data to the fastcgi backend, instead it just need to use the default handler for that purpose.

Member

edsiper commented Dec 14, 2015

thanks for the report.

The problem was that the fastcgi plugin was using the tls network API to write data to the fastcgi backend, instead it just need to use the default handler for that purpose.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment