Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
42 lines (26 sloc) 1.13 KB
Prerequisites
=============
You will need:
Mono 1.1.9
Gtk# 2.5.5.99
Gecko# 0.10
GCC 3.3
Gtk+ 2.6 + developer headers
Mozilla 1.7.10 + developer headers
Newer versions should work; if they don't, it's a bug.
Building AspNetEdit
===================
Open a terminal in the root aspnetedit director and run the following commands
./autogen.sh --prefix=PREFIX
make
Installing AspNetEdit
=====================
To install AspNetEdit into the PREFIX directory you specified when running autoconf.sh, simply run
make install
The executable and libraries will be installed into PREFIX/lib, and a script 'aspnetedit' is provided in PREFIX/bin to launch the application.
The Mozilla extension that AspNetEdit requires is installed into the 'chrome' subdirectory of your Mozilla installation, for which you will need write access.
Running AspNetEdit directly
===========================
You can run AspNetEdit out of the build directory with the command
make run
However, the Mozilla extension *must* be installed first, so this command is only useful for running updated builds of the Mono-based components without reinstalling the whole application.