Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

2007-12-11 Mike Kestner <mkestner@novell.com>

	* configure.in.in: move vte, rsvg, and gtkhtml to gnome-desktop-sharp.
	* Makefile.am: ditto
	* sample/Makefile.am: ditto

svn path=/trunk/gnome-sharp/; revision=91109
  • Loading branch information...
commit 4f0a161f8e535e90a011d4e6b89aa119e49c14fa 1 parent e8c112d
@mkestner mkestner authored
Showing with 11 additions and 74 deletions.
  1. +6 −0 ChangeLog
  2. +1 −1  Makefile.am
  3. +1 −58 configure.in.in
  4. +3 −15 sample/Makefile.am
View
6 ChangeLog
@@ -1,3 +1,9 @@
+2007-12-11 Mike Kestner <mkestner@novell.com>
+
+ * configure.in.in: move vte, rsvg, and gtkhtml to gnome-desktop-sharp.
+ * Makefile.am: ditto
+ * sample/Makefile.am: ditto
+
2007-12-07 Mike Kestner <mkestner@novell.com>
* Makefile.include: some refinement of the variable mangling.
View
2  Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = sources art gnomevfs gnome gtkhtml gconf rsvg vte sample
+SUBDIRS = sources art gnomevfs gnome gconf sample
EXTRA_DIST = \
gtk-sharp.snk \
View
59 configure.in.in
@@ -173,7 +173,7 @@ AC_SUBST(GAPI_FIXUP)
## Versions of dependencies
GNOME_REQUIRED_VERSION=@GNOME_REQUIRED_VERSION@
-ART_REQUIRED_VERSION=2.3.16
+ART_REQUIRED_VERSION=2.3.19
PKG_CHECK_MODULES(LIBART, libart-2.0 >= $ART_REQUIRED_VERSION, enable_libart=yes, enable_libart=no)
AC_SUBST(LIBART_CFLAGS)
@@ -191,55 +191,9 @@ PKG_CHECK_MODULES(GNOME, libgnomecanvas-2.0 >= $GNOMECANVAS_REQUIRED_VERSION lib
AC_SUBST(GNOME_CFLAGS)
AC_SUBST(GNOME_LIBS)
-RSVG_REQUIRED_VERSION=2.0.1
-PKG_CHECK_MODULES(RSVG_DEPENDENCIES, librsvg-2.0 >= $RSVG_REQUIRED_VERSION, enable_rsvg=yes, enable_rsvg=no)
-
-if test "x$enable_gnome" = "xyes"; then
-GTKHTML_REQUIRED_VERSION=3.8.0
-PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
-if test "x$enable_gtkhtml" = "xyes"; then
-GTKHTML_VERSION=3.8
-GTKHTML_SOVERSION=15
-else
-GTKHTML_REQUIRED_VERSION=3.6.0
-PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.6 >= $GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
-if test "x$enable_gtkhtml" = "xyes"; then
-GTKHTML_VERSION=3.6
-GTKHTML_SOVERSION=18
-else
-GTKHTML_REQUIRED_VERSION=3.2.0
-PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.1 >= $GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
-if test "x$enable_gtkhtml" = "xyes"; then
-GTKHTML_VERSION=3.1
-GTKHTML_SOVERSION=11
-else
-GTKHTML_REQUIRED_VERSION=3.0.10
-PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.0 >= $GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
-if test "x$enable_gtkhtml" = "xyes"; then
-GTKHTML_VERSION=3.0
-GTKHTML_SOVERSION=4
-else
-GTKHTML_VERSION=
-GTKHTML_SOVERSION=
-fi
-fi
-fi
-fi
-AC_SUBST(GTKHTML_VERSION)
-AC_SUBST(GTKHTML_SOVERSION)
-else
-enable_gtkhtml=no
-fi
-
-VTE_REQUIRED_VERSION=0.11.10
-PKG_CHECK_MODULES(VTE_DEPENDENCIES, vte >= $VTE_REQUIRED_VERSION gtk+-2.0 >= $GTK_REQUIRED_VERSION, enable_vte=yes, enable_vte=no)
-
AM_CONDITIONAL(ENABLE_LIBART, test "x$enable_libart" = "xyes")
AM_CONDITIONAL(ENABLE_GNOMEVFS, test "x$enable_gnomevfs" = "xyes")
AM_CONDITIONAL(ENABLE_GNOME, test "x$enable_gnome" = "xyes")
-AM_CONDITIONAL(ENABLE_RSVG, test "x$enable_rsvg" = "xyes")
-AM_CONDITIONAL(ENABLE_GTKHTML, test "x$enable_gtkhtml" = "xyes")
-AM_CONDITIONAL(ENABLE_VTE, test "x$enable_vte" = "xyes")
AM_CONDITIONAL(ENABLE_MONOGETOPTIONS, test "x$has_mono" = "xtrue")
AC_SUBST(CFLAGS)
@@ -268,20 +222,9 @@ gconf/GConf.PropertyEditors/Makefile
gconf/GConf.PropertyEditors/gconf-sharp-peditors-2.0.pc
gconf/tools/Makefile
gconf/tools/gconfsharp2-schemagen
-gtkhtml/Makefile
-gtkhtml/gtkhtml-sharp.dll.config
-gtkhtml/gtkhtml-sharp-2.0.pc
-rsvg/Makefile
-rsvg/rsvg-sharp.dll.config
-rsvg/rsvg-sharp-2.0.pc
-vte/Makefile
-vte/glue/Makefile
-vte/vte-sharp.dll.config
-vte/vte-sharp-2.0.pc
sample/Makefile
sample/gconf/Makefile
sample/gnomevfs/Makefile
-sample/rsvg/Makefile
])
echo "---"
View
18 sample/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = gconf rsvg gnomevfs
+SUBDIRS = gconf gnomevfs
if ENABLE_GNOME
GNOME_TARGETS=gnome-hello-world.exe canvas-example.exe fifteen.exe print.exe
@@ -16,19 +16,11 @@ GNOMEVFS_TARGETS=
GNOMEVFS_ASSEMBLY=
endif
-if ENABLE_VTE
-VTE_TARGETS=vte-example.exe
-VTE_ASSEMBLY=../vte/vte-sharp.dll
-else
-VTE_TARGETS=
-VTE_ASSEMBLY=
-endif
-
-TARGETS = $(GNOMEVFS_TARGETS) $(GNOME_TARGETS) $(VTE_TARGETS)
+TARGETS = $(GNOMEVFS_TARGETS) $(GNOME_TARGETS)
DEBUGS = $(addsuffix .mdb, $(TARGETS))
-assemblies= $(GNOMEVFS_ASSEMBLY) $(GNOME_ASSEMBLY) $(VTE_ASSEMBLY)
+assemblies= $(GNOMEVFS_ASSEMBLY) $(GNOME_ASSEMBLY)
references=$(GTKSHARP_LIBS) $(addprefix /r:, $(assemblies))
noinst_SCRIPTS = $(TARGETS)
@@ -46,9 +38,6 @@ fifteen.exe: $(srcdir)/Fifteen.cs $(assemblies)
print.exe: $(srcdir)/PrintSample.cs $(assemblies)
$(CSC) /out:print.exe $(references) $(srcdir)/PrintSample.cs
-vte-example.exe: $(srcdir)/VteTest.cs $(assemblies)
- $(CSC) /debug /unsafe /out:vte-example.exe $(references) $(srcdir)/VteTest.cs
-
testvfs.exe: $(srcdir)/TestVfs.cs $(assemblies)
$(CSC) /debug /out:testvfs.exe $(references) $(srcdir)/TestVfs.cs
@@ -57,5 +46,4 @@ EXTRA_DIST = \
CanvasExample.cs \
Fifteen.cs \
PrintSample.cs \
- VteTest.cs \
TestVfs.cs
Please sign in to comment.
Something went wrong with that request. Please try again.