Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't install Mono from Mono repo for Fedora 29 #11937

Closed
briguyjm opened this issue Dec 4, 2018 · 12 comments
Closed

Can't install Mono from Mono repo for Fedora 29 #11937

briguyjm opened this issue Dec 4, 2018 · 12 comments
Labels

Comments

@briguyjm
Copy link

@briguyjm briguyjm commented Dec 4, 2018

Steps to Reproduce

  1. Add the mono Fedora repo per the instructions on the website
  2. Install package mono-complete

this is the output of sudo dnf install mono-complete

Error: 
 Problem: conflicting requests
  - package mono-complete-3.10.0-1.x86_64 requires mono-core = 3.10.0, but none of the providers can be installed
  - package mono-complete-3.10.0-2.x86_64 requires mono-core = 3.10.0, but none of the providers can be installed
  - package mono-complete-3.12.0-0.x86_64 requires mono-core = 3.12.0, but none of the providers can be installed
  - package mono-complete-3.12.0-1.x86_64 requires mono-core = 3.12.0, but none of the providers can be installed
  - package mono-complete-3.12.0-2.x86_64 requires mono-core = 3.12.0, but none of the providers can be installed
  - package mono-complete-3.12.1-0.x86_64 requires mono-core = 3.12.1, but none of the providers can be installed
  - package mono-complete-3.8.0-1.x86_64 requires mono-core = 3.8.0, but none of the providers can be installed
  - package mono-complete-4.0.1-1.x86_64 requires mono-core = 4.0.1, but none of the providers can be installed
  - package mono-complete-4.0.1-2.x86_64 requires mono-core = 4.0.1, but none of the providers can be installed
  - package mono-complete-4.0.1-3.x86_64 requires mono-core = 4.0.1, but none of the providers can be installed
  - package mono-complete-4.0.1-4.x86_64 requires mono-core = 4.0.1, but none of the providers can be installed
  - package mono-complete-4.0.1.44-0.xamarin.1.x86_64 requires mono-core = 4.0.1.44, but none of the providers can be installed
  - package mono-complete-4.0.2.5-0.xamarin.1.x86_64 requires mono-core = 4.0.2.5, but none of the providers can be installed
  - package mono-complete-4.0.3.20-0.xamarin.1.x86_64 requires mono-core = 4.0.3.20, but none of the providers can be installed
  - package mono-complete-4.0.3.20-0.xamarin.4.x86_64 requires mono-core = 4.0.3.20, but none of the providers can be installed
  - package mono-complete-4.0.4.1-0.xamarin.1.x86_64 requires mono-core = 4.0.4.1, but none of the providers can be installed
  - package mono-complete-4.0.5.1-0.xamarin.1.x86_64 requires mono-core = 4.0.5.1, but none of the providers can be installed
  - package mono-complete-4.2.1.102-0.xamarin.1.x86_64 requires mono-core = 4.2.1.102, but none of the providers can be installed
  - package mono-complete-4.2.2.30-0.xamarin.1.x86_64 requires mono-core = 4.2.2.30, but none of the providers can be installed
  - package mono-complete-4.2.2.30-0.xamarin.2.x86_64 requires mono-core = 4.2.2.30, but none of the providers can be installed
  - package mono-complete-4.2.3.4-0.xamarin.1.x86_64 requires mono-core = 4.2.3.4, but none of the providers can be installed
  - package mono-complete-4.2.4.4-0.xamarin.1.x86_64 requires mono-core = 4.2.4.4, but none of the providers can be installed
  - package mono-complete-4.4.1.0-0.xamarin.1.x86_64 requires mono-core = 4.4.1.0, but none of the providers can be installed
  - package mono-complete-4.4.2.11-0.xamarin.1.x86_64 requires mono-core = 4.4.2.11, but none of the providers can be installed
  - package mono-complete-4.6.0.245-0.xamarin.4.x86_64 requires mono-core = 4.6.0.245, but none of the providers can be installed
  - package mono-complete-4.6.1.3-0.xamarin.2.x86_64 requires mono-core = 4.6.1.3, but none of the providers can be installed
  - package mono-complete-4.6.1.5-0.xamarin.1.x86_64 requires mono-core = 4.6.1.5, but none of the providers can be installed
  - package mono-complete-4.6.2.16-0.xamarin.1.x86_64 requires mono-core = 4.6.2.16, but none of the providers can be installed
  - package mono-complete-4.6.2.7-0.xamarin.1.x86_64 requires mono-core = 4.6.2.7, but none of the providers can be installed
  - package mono-complete-4.8.0.495-0.xamarin.1.x86_64 requires mono-core = 4.8.0.495, but none of the providers can be installed
  - package mono-complete-4.8.0.520-0.xamarin.1.x86_64 requires mono-core = 4.8.0.520, but none of the providers can be installed
  - package mono-complete-4.8.0.524-0.xamarin.1.x86_64 requires mono-core = 4.8.0.524, but none of the providers can be installed
  - package mono-complete-4.8.1.0-0.xamarin.1.x86_64 requires mono-core = 4.8.1.0, but none of the providers can be installed
  - package mono-complete-5.0.0.100-0.xamarin.1.epel7.x86_64 requires mono-core = 5.0.0.100, but none of the providers can be installed
  - package mono-complete-5.0.1.1-0.xamarin.3.epel7.x86_64 requires mono-core = 5.0.1.1, but none of the providers can be installed
  - package mono-complete-5.10.0.140-0.xamarin.2.epel7.x86_64 requires mono-core = 5.10.0.140, but none of the providers can be installed
  - package mono-complete-5.10.0.160-0.xamarin.1.epel7.x86_64 requires mono-core = 5.10.0.160, but none of the providers can be installed
  - package mono-complete-5.10.1.20-0.xamarin.3.epel7.x86_64 requires mono-core = 5.10.1.20, but none of the providers can be installed
  - package mono-complete-5.10.1.4-0.xamarin.3.epel7.x86_64 requires mono-core = 5.10.1.4, but none of the providers can be installed
  - package mono-complete-5.10.1.47-0.xamarin.3.epel7.x86_64 requires mono-core = 5.10.1.47, but none of the providers can be installed
  - package mono-complete-5.12.0.233-0.xamarin.3.epel7.x86_64 requires mono-core = 5.12.0.233, but none of the providers can be installed
  - package mono-complete-5.12.0.301-0.xamarin.1.epel7.x86_64 requires mono-core = 5.12.0.301, but none of the providers can be installed
  - package mono-complete-5.14.0.177-0.xamarin.1.epel7.x86_64 requires mono-core = 5.14.0.177, but none of the providers can be installed
  - package mono-complete-5.16.0.187-0.xamarin.3.epel7.x86_64 requires mono-core = 5.16.0.187, but none of the providers can be installed
  - package mono-complete-5.16.0.220-0.xamarin.4.epel7.x86_64 requires mono-core = 5.16.0.220, but none of the providers can be installed
  - package mono-complete-5.2.0.215-0.xamarin.3.epel7.x86_64 requires mono-core = 5.2.0.215, but none of the providers can be installed
  - package mono-complete-5.2.0.224-0.xamarin.1.epel7.x86_64 requires mono-core = 5.2.0.224, but none of the providers can be installed
  - package mono-complete-5.4.0.201-0.xamarin.1.epel7.x86_64 requires mono-core = 5.4.0.201, but none of the providers can be installed
  - package mono-complete-5.4.1.6-0.xamarin.1.epel7.x86_64 requires mono-core = 5.4.1.6, but none of the providers can be installed
  - package mono-complete-5.4.1.7-0.xamarin.2.epel7.x86_64 requires mono-core = 5.4.1.7, but none of the providers can be installed
  - package mono-complete-5.8.0.108-0.xamarin.2.epel7.x86_64 requires mono-core = 5.8.0.108, but none of the providers can be installed
  - package mono-complete-5.8.0.127-0.xamarin.2.epel7.x86_64 requires mono-core = 5.8.0.127, but none of the providers can be installed
  - package mono-complete-5.8.0.127-0.xamarin.3.epel7.x86_64 requires mono-core = 5.8.0.127, but none of the providers can be installed
  - package mono-core-3.10.0-1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-3.10.0-2.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-3.12.0-0.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-3.12.0-1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-3.12.0-2.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-3.12.1-0.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-3.8.0-1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.1-1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.1-2.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.1-3.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.1-4.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.1.44-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.2.5-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.3.20-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.3.20-0.xamarin.4.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.4.1-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.0.5.1-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.2.1.102-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.2.2.30-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.2.2.30-0.xamarin.2.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.2.3.4-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.2.4.4-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.4.1.0-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.4.2.11-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.6.0.245-0.xamarin.4.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.6.1.3-0.xamarin.2.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.6.1.5-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.6.2.16-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.6.2.7-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.8.0.495-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.8.0.520-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.8.0.524-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-4.8.1.0-0.xamarin.1.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.0.0.100-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.0.1.1-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.10.0.140-0.xamarin.2.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.10.0.160-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.10.1.20-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.10.1.4-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.10.1.47-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.12.0.233-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.12.0.301-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.14.0.177-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.16.0.187-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.16.0.220-0.xamarin.4.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.2.0.215-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.2.0.224-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.4.0.201-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.4.1.6-0.xamarin.1.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.4.1.7-0.xamarin.2.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.8.0.108-0.xamarin.2.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.8.0.127-0.xamarin.2.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - package mono-core-5.8.0.127-0.xamarin.3.epel7.x86_64 requires libgdiplus0, but none of the providers can be installed
  - nothing provides libgif.so.4()(64bit) needed by libgdiplus0-3.12-0.x86_64
  - nothing provides libgif.so.4()(64bit) needed by libgdiplus0-3.12-1.x86_64
  - nothing provides libgif.so.4()(64bit) needed by libgdiplus0-3.8-0.x86_64
  - nothing provides libgif.so.4()(64bit) needed by libgdiplus0-4.2-0.xamarin.2.epel7.x86_64
  - nothing provides libgif.so.4()(64bit) needed by libgdiplus0-5.6-0.xamarin.1.epel7.x86_64

I also tried specifying a specific version of the package and had the same issue.

@briguyjm briguyjm changed the title Can't install Mono from repo Can't install Mono from Mono repo for Fedora Dec 4, 2018
@luhenry
Copy link
Member

@luhenry luhenry commented Dec 5, 2018

@directhex
Copy link
Contributor

@directhex directhex commented Dec 5, 2018

I knew adding Fedora download instructions - a distro we don't actually build for - was a mistake.

Which version of Fedora?

@briguyjm
Copy link
Author

@briguyjm briguyjm commented Dec 6, 2018

I'm on Fedora 29. Things worked on Fedora 28. Rather than update I opted to reinstall Fedora, which is why I'm now having issues.

@briguyjm briguyjm changed the title Can't install Mono from Mono repo for Fedora Can't install Mono from Mono repo for Fedora 29 Dec 6, 2018
@directhex
Copy link
Contributor

@directhex directhex commented Dec 6, 2018

@briguyjm
Copy link
Author

@briguyjm briguyjm commented Dec 9, 2018

This seems to be working now. I was able to install the mono-complete package with no issues.

@lewurm lewurm closed this Dec 14, 2018
@tdgroot
Copy link

@tdgroot tdgroot commented Jan 9, 2019

FWIW: I created a blog post about my findings when installing Mono 5 on Fedora 29: https://blog.timpack.org/fedora-29-and-mono-5.

@Lecomsys
Copy link

@Lecomsys Lecomsys commented Jan 21, 2019

@theodore-dream
Copy link

@theodore-dream theodore-dream commented Oct 27, 2019

Note - these instructions are now outdated. I got 404 error upon trying to install the compat-giflib package of concern, I was able to find this archive 3rd party site with the package:

http://rpm.pbone.net/index.php3/stat/4/idpl/50447027/dir/fedora_28/com/compat-giflib-4.1.6-1.fc28.x86_64.rpm.html

They seemed to make reference to some fedora archive page. For the next person investigating this, my note is that this above source does not seem reliable and this could be risky to rely on this source, I would say if someone is able to find a fedora archive page with the proper package from official source this would be best.

On digging I did find a page explaining on redhat bugzilla that the version 4.1.6 was being retired as it was only a placeholder in F28 for giflib-5 or something like that, so this helps explain why this issue has arisen. Hope this helps.

@directhex
Copy link
Contributor

@directhex directhex commented Oct 28, 2019

This is wildly out of date. Use the RHEL 8 repo for FC29.

@29217321
Copy link

@29217321 29217321 commented Feb 9, 2020

Hi I got the same error of missing "libgdiplus0-6.0.4-0.xamarin.1.epel7.src.rpm" when I install Mono 6.6 from RPM to CentOS 7.7, can some body suggest please?

@directhex
Copy link
Contributor

@directhex directhex commented Feb 10, 2020

What's the full error output

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
10 participants