Permalink
Browse files

Prepping for 2.0.3 release

svn path=/trunk/uia2atk/; revision=155885
  • Loading branch information...
decriptor committed Apr 21, 2010
1 parent b6913c2 commit fc1d44ea54fd30780dbb28517fd40308263c3f6f
View
@@ -3,6 +3,14 @@ Mono Accessibility News
Copyright (C) 2008 - 2010 Novell, Inc. (http://www.novell.com)
+Version 2.0.3: The "infotainment" release
+* #590765 - GridSpliter: Crash When Selected
+* #590708 - Fail to run IronPython Winforms application after install at-spi2
+* #586360 - Ironpython sample doesn't accessible after install at-spi1 and at-spi2
+* #596801 - [uiaclient-GTKs]: The disable button became a enable button, but its IsEnableProperty still be false
+* #593973 - GTK sub window can not be refreshed
+* #592185 - Supported AutomationElement returns AutomationElement.NotSupported
+
Version 2.0.2: The "heliport" release
* #587792 - TabControl: select invisible label child make the application crashed
* #563890 - GridSplitter: run with Orca couldn't use Up|Down Right|Left to move splitter
@@ -1,5 +1,5 @@
AC_PREREQ([2.54])
-AC_INIT([AtspiUiaSource], [2.0.2])
+AC_INIT([AtspiUiaSource], [2.0.3])
AM_INIT_AUTOMAKE([foreign])
# pkg-config
@@ -38,7 +38,7 @@ AC_ARG_ENABLE(tests,
NUNIT_PATH=
-PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.2])
+PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.3])
PKG_CHECK_MODULES(NUNIT, mono-nunit >= 2.4, nunit_24=yes, nunit_24=no)
if test "x$nunit_24" = "xno"; then
AC_MSG_WARN([Could not find mono-nunit >= 2.4; unit tests will not be available.])
@@ -23,7 +23,7 @@ Summary: At-spi uia source
BuildRequires: at-spi-sharp-devel >= 1.0
BuildRequires: glib-sharp2 >= 2.12.8
BuildRequires: mono-devel >= 2.4
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia-devel >= 2.0.3
BuildRequires: pkg-config
%description
View
@@ -3,6 +3,14 @@ Mono Accessibility News
Copyright (C) 2008 - 2010 Novell, Inc. (http://www.novell.com)
+Version 2.0.3: The "infotainment" release
+* #590765 - GridSpliter: Crash When Selected
+* #590708 - Fail to run IronPython Winforms application after install at-spi2
+* #586360 - Ironpython sample doesn't accessible after install at-spi1 and at-spi2
+* #596801 - [uiaclient-GTKs]: The disable button became a enable button, but its IsEnableProperty still be false
+* #593973 - GTK sub window can not be refreshed
+* #592185 - Supported AutomationElement returns AutomationElement.NotSupported
+
Version 2.0.2: The "heliport" release
* #587792 - TabControl: select invisible label child make the application crashed
* #563890 - GridSplitter: run with Orca couldn't use Up|Down Right|Left to move splitter
@@ -1,5 +1,5 @@
AC_PREREQ([2.54])
-AC_INIT([MoonAtkBridge], [2.0.2])
+AC_INIT([MoonAtkBridge], [2.0.3])
AM_INIT_AUTOMAKE([foreign])
# pkg-config
View
@@ -3,6 +3,14 @@ Mono Accessibility News
Copyright (C) 2008 - 2010 Novell, Inc. (http://www.novell.com)
+Version 2.0.3: The "infotainment" release
+* #590765 - GridSpliter: Crash When Selected
+* #590708 - Fail to run IronPython Winforms application after install at-spi2
+* #586360 - Ironpython sample doesn't accessible after install at-spi1 and at-spi2
+* #596801 - [uiaclient-GTKs]: The disable button became a enable button, but its IsEnableProperty still be false
+* #593973 - GTK sub window can not be refreshed
+* #592185 - Supported AutomationElement returns AutomationElement.NotSupported
+
Version 2.0.2: The "heliport" release
* #587792 - TabControl: select invisible label child make the application crashed
* #563890 - GridSplitter: run with Orca couldn't use Up|Down Right|Left to move splitter
@@ -1,7 +1,7 @@
dnl Warning: This is an automatically generated file, do not edit!
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ([2.54])
-AC_INIT([mono-uia],[2.0.2])
+AC_INIT([mono-uia],[2.0.3])
AM_INIT_AUTOMAKE([foreign 1.9 tar-ustar])
dnl pkg-config
@@ -3,6 +3,14 @@ Mono Accessibility News
Copyright (C) 2008 - 2010 Novell, Inc. (http://www.novell.com)
+Version 2.0.3: The "infotainment" release
+* #590765 - GridSpliter: Crash When Selected
+* #590708 - Fail to run IronPython Winforms application after install at-spi2
+* #586360 - Ironpython sample doesn't accessible after install at-spi1 and at-spi2
+* #596801 - [uiaclient-GTKs]: The disable button became a enable button, but its IsEnableProperty still be false
+* #593973 - GTK sub window can not be refreshed
+* #592185 - Supported AutomationElement returns AutomationElement.NotSupported
+
Version 2.0.2: The "heliport" release
* #587792 - TabControl: select invisible label child make the application crashed
* #563890 - GridSplitter: run with Orca couldn't use Up|Down Right|Left to move splitter
@@ -1,7 +1,7 @@
dnl Warning: This is an automatically generated file, do not edit!
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ([2.54])
-AC_INIT([UIAutomationWinforms], [2.0.2])
+AC_INIT([UIAutomationWinforms], [2.0.3])
AM_INIT_AUTOMAKE([foreign 1.9 tar-ustar])
IT_PROG_INTLTOOL([0.35.0])
@@ -81,7 +81,7 @@ AC_SUBST(NUNIT_PATH)
AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "xyes")
dnl package checks, common for all configs
-PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.2])
+PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.3])
PKG_CHECK_MODULES([MONO], [mono >= 2.4])
gacutil -l System.Data | grep "Version=2"
@@ -23,20 +23,20 @@ Requires: glib-sharp2 >= 2.12.8
Requires: gtk-sharp2 >= 2.12.8
Requires: mono-core >= 2.4
Requires: mono-data >= 2.4
-Requires: mono-uia >= 2.0.2
+Requires: mono-uia >= 2.0.3
Requires: mono-winfxcore
-Requires: uiaatkbridge >= 2.0.2
+Requires: uiaatkbridge >= 2.0.3
BuildRequires: gtk-sharp2 >= 2.12.8
BuildRequires: glib-sharp2 >= 2.12.8
BuildRequires: intltool
BuildRequires: mono-devel >= 2.4
BuildRequires: mono-data >= 2.4
BuildRequires: mono-nunit >= 2.4
-BuildRequires: mono-uia >= 2.0.2
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia >= 2.0.3
+BuildRequires: mono-uia-devel >= 2.0.3
BuildRequires: mono-winfxcore
BuildRequires: pkg-config
-BuildRequires: uiaatkbridge >= 2.0.2
+BuildRequires: uiaatkbridge >= 2.0.3
Summary: Implementation of UIA providers
View
@@ -3,6 +3,14 @@ Mono Accessibility News
Copyright (C) 2008 - 2010 Novell, Inc. (http://www.novell.com)
+Version 2.0.3: The "infotainment" release
+* #590765 - GridSpliter: Crash When Selected
+* #590708 - Fail to run IronPython Winforms application after install at-spi2
+* #586360 - Ironpython sample doesn't accessible after install at-spi1 and at-spi2
+* #596801 - [uiaclient-GTKs]: The disable button became a enable button, but its IsEnableProperty still be false
+* #593973 - GTK sub window can not be refreshed
+* #592185 - Supported AutomationElement returns AutomationElement.NotSupported
+
Version 2.0.2: The "heliport" release
* #587792 - TabControl: select invisible label child make the application crashed
* #563890 - GridSplitter: run with Orca couldn't use Up|Down Right|Left to move splitter
@@ -1,5 +1,5 @@
AC_PREREQ([2.54])
-AC_INIT([UiaAtkBridge], [2.0.2])
+AC_INIT([UiaAtkBridge], [2.0.3])
AM_INIT_AUTOMAKE([foreign])
# pkg-config
@@ -93,7 +93,7 @@ PKG_CHECK_MODULES([GTK_SHARP_20], [gtk-sharp-2.0 >= 2.12.8])
PKG_CHECK_MODULES(GTK_SHARP_2_12_10, gtk-sharp-2.0 >= 2.12.10, [last_gtk_sharp=yes], [last_gtk_sharp=no])
AM_CONDITIONAL(HAVE_OLD_ATK_SHARP, test x$last_gtk_sharp = xno)
-PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.2])
+PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.3])
#Bridge-glue checks
PKG_CHECK_MODULES(ATK, atk)
@@ -21,15 +21,13 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires: at-spi >= 1.24.0
Requires: gtk-sharp2 >= 2.12.8
Requires: mono-core >= 2.4
-Requires: mono-uia >= 2.0.2
-Requires: mono-winfxcore
+Requires: mono-uia >= 2.0.3
BuildRequires: atk-devel >= 1.24
BuildRequires: gtk2-devel >= 2.14
BuildRequires: gtk-sharp2 >= 2.12.8
BuildRequires: mono-devel >= 2.4
-BuildRequires: mono-uia >= 2.0.2
-BuildRequires: mono-uia-devel >= 2.0.2
-BuildRequires: mono-winfxcore
+BuildRequires: mono-uia >= 2.0.3
+BuildRequires: mono-uia-devel >= 2.0.3
Summary: Bridge between UIA providers and ATK
@@ -44,6 +42,7 @@ Automation core to send it automation events and provider information.
%build
%configure --disable-tests
+#make %{?_smp_mflags}
make
%install
View
@@ -3,6 +3,14 @@ Mono Accessibility News
Copyright (C) 2008 - 2010 Novell, Inc. (http://www.novell.com)
+Version 2.0.3: The "infotainment" release
+* #590765 - GridSpliter: Crash When Selected
+* #590708 - Fail to run IronPython Winforms application after install at-spi2
+* #586360 - Ironpython sample doesn't accessible after install at-spi1 and at-spi2
+* #596801 - [uiaclient-GTKs]: The disable button became a enable button, but its IsEnableProperty still be false
+* #593973 - GTK sub window can not be refreshed
+* #592185 - Supported AutomationElement returns AutomationElement.NotSupported
+
Version 2.0.2: The "heliport" release
* #587792 - TabControl: select invisible label child make the application crashed
* #563890 - GridSplitter: run with Orca couldn't use Up|Down Right|Left to move splitter
View
@@ -1,5 +1,5 @@
AC_PREREQ([2.54])
-AC_INIT([UiaDbus], [2.0.2])
+AC_INIT([UiaDbus], [2.0.3])
AM_INIT_AUTOMAKE([foreign])
# pkg-config
@@ -90,7 +90,7 @@ AM_CONDITIONAL(ENABLE_EXTERNAL_NDESK_DBUS, test "x$enable_external_ndesk_dbus" =
# package checks, common for all configs
PKG_CHECK_MODULES([GLIB_SHARP_20], [glib-sharp-2.0 >= 2.12.8])
-PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.2])
+PKG_CHECK_MODULES([MONO_UIA], [mono-uia >= 2.0.3])
TOPDIR=$PWD
AC_SUBST(TOPDIR)
@@ -21,7 +21,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-build
Summary: UiaDbus components of UIA on Linux
BuildRequires: glib-sharp2
BuildRequires: mono-devel >= 2.4
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia-devel >= 2.0.3
BuildRequires: ndesk-dbus
BuildRequires: pkg-config
@@ -4,7 +4,7 @@
#
Name: atspiuiasource
-Version: 2.0.2
+Version: 2.0.3
Release: 1
License: MIT
Group: System/Libraries
@@ -15,7 +15,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: at-spi-sharp-devel
BuildRequires: gtk-sharp2-devel >= 2.12.8
BuildRequires: mono-devel >= 2.4
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia-devel >= 2.0.3
Summary: At-spi uia source
%description
@@ -4,7 +4,7 @@
#
Name: mono-uia
-Version: 2.0.2
+Version: 2.0.3
Release: 1
License: MIT
Group: System/Libraries
@@ -47,7 +47,7 @@ WinFx components required by User Interface Automation (UIA) for use with Mono
%build
%configure --disable-tests --enable-winfxcore
-#Break build with parrallel make
+# Parallel build fails
make
%install
@@ -4,7 +4,7 @@
#
Name: uiaatkbridge
-Version: 2.0.2
+Version: 2.0.3
Release: 1
License: MIT
Group: System/Libraries
@@ -15,14 +15,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: at-spi >= 1.24.0
Requires: gtk-sharp2 >= 2.12.8
Requires: mono-core >= 2.4
-Requires: mono-uia >= 2.0.2
+Requires: mono-uia >= 2.0.3
BuildRequires: atk-devel >= 1.24
BuildRequires: gtk2-devel >= 2.14
#BuildRequires: gtk-sharp2 >= 2.12.8
BuildRequires: gtk-sharp2-devel >= 2.12.8
BuildRequires: mono-devel >= 2.4
-BuildRequires: mono-uia >= 2.0.2
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia >= 2.0.3
+BuildRequires: mono-uia-devel >= 2.0.3
Summary: Bridge between UIA providers and ATK
@@ -4,7 +4,7 @@
#
Name: uiadbus
-Version: 2.0.2
+Version: 2.0.3
Release: 1
License: MIT
Group: System/Libraries
@@ -14,7 +14,7 @@ Patch0: uiadbus-libdir.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gtk-sharp2-devel >= 2.12.8
BuildRequires: mono-devel >= 2.4
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia-devel >= 2.0.3
BuildRequires: ndesk-dbus
Summary: UiaDbus components of UIA on Linux
@@ -4,7 +4,7 @@
#
Name: uiautomationwinforms
-Version: 2.0.2
+Version: 2.0.3
Release: 1
License: MIT
Group: System/Libraries
@@ -15,14 +15,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: gtk-sharp2 >= 2.12.8
Requires: mono-core >= 2.4
Requires: mono-data >= 2.4
-Requires: mono-uia >= 2.0.2
-Requires: uiaatkbridge >= 2.0.2
+Requires: mono-uia >= 2.0.3
+Requires: uiaatkbridge >= 2.0.3
BuildRequires: gtk-sharp2-devel >= 2.12.8
BuildRequires: mono-devel >= 2.4
BuildRequires: mono-data >= 2.4
BuildRequires: mono-nunit >= 2.4
-BuildRequires: mono-uia >= 2.0.2
-BuildRequires: mono-uia-devel >= 2.0.2
+BuildRequires: mono-uia >= 2.0.3
+BuildRequires: mono-uia-devel >= 2.0.3
BuildRequires: intltool
Summary: Implementation of UIA providers

0 comments on commit fc1d44e

Please sign in to comment.