Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Install 4.x version into correct location. Fixes #2876

commit d3e2f80ff59ddff68e757a520655555e2fbf2695 1 parent d7bd344
@marek-safar marek-safar authored
View
2  scripts/Makefile.am
@@ -20,7 +20,7 @@ plat_bindir2 = $(prefix)/lib/mono/2.0
plat_tooldir2 = $(prefix)/lib/xsp/2.0
if NET_4_0
-plat_bindir4 = $(prefix)/lib/mono/4.0
+plat_bindir4 = $(prefix)/lib/mono/4.5
plat_tooldir4 = $(prefix)/lib/xsp/4.0
endif
View
2  src/Mono.WebServer.Apache/Makefile.am
@@ -7,7 +7,7 @@ GACUTIL2=$(GACUTIL) -package 2.0
if NET_4_0
MODMONOSERVER4_EXE = mod-mono-server4.exe
-GACUTIL4=$(GACUTIL) -package 4.0
+GACUTIL4=$(GACUTIL) -package 4.5
endif
noinst_SCRIPTS = $(MODMONOSERVER2_EXE) $(MODMONOSERVER4_EXE)
View
2  src/Mono.WebServer.FastCgi/Makefile.am
@@ -7,7 +7,7 @@ GACUTIL2=$(GACUTIL) -package 2.0
if NET_4_0
XSP4_EXE = fastcgi-mono-server4.exe
-GACUTIL4=$(GACUTIL) -package 4.0
+GACUTIL4=$(GACUTIL) -package 4.5
endif
noinst_SCRIPTS = $(XSP2_EXE) $(XSP4_EXE)
View
2  src/Mono.WebServer.XSP/Makefile.am
@@ -8,7 +8,7 @@ GACUTIL2=$(GACUTIL) -package 2.0
if NET_4_0
XSP4_EXE = xsp4.exe
-GACUTIL4=$(GACUTIL) -package 4.0
+GACUTIL4=$(GACUTIL) -package 4.5
endif
noinst_SCRIPTS = $(XSP2_EXE) $(XSP4_EXE)
View
2  src/Mono.WebServer.XSP/xsp-4.pc.in
@@ -1,5 +1,5 @@
prefix=@prefix@
-assemblies_dir=${prefix}/lib/mono/4.0
+assemblies_dir=${prefix}/lib/mono/4.5
Libraries=${assemblies_dir}/Mono.WebServer2.dll
Executable=${assemblies_dir}/xsp4.exe
View
4 src/Mono.WebServer/Makefile.am
@@ -9,10 +9,10 @@ monowebserver2_references = -r:System.Web.dll -r:System.Configuration.dll -r:Mon
GACUTIL2=$(GACUTIL) -package 2.0
if NET_4_0
-monowebserver4dir = $(prefix)/lib/xsp/4.0
+monowebserver4dir = $(prefix)/lib/xsp/4.5
monowebserver4_install = 4.0/Mono.WebServer2.dll
monowebserver4_references = $(monowebserver2_references)
-GACUTIL4=$(GACUTIL) -package 4.0
+GACUTIL4=$(GACUTIL) -package 4.5
endif
noinst_SCRIPTS= $(monowebserver2_install) $(monowebserver4_install)
View
8 xsp.spec.in
@@ -79,10 +79,10 @@ rm -rf %{buildroot}
%{_prefix}/lib/mono/2.0/fastcgi-mono-server2.exe
%{_prefix}/lib/mono/2.0/mod-mono-server2.exe
%{_prefix}/lib/mono/2.0/xsp2.exe
-%{_prefix}/lib/mono/4.0/Mono.WebServer2.dll
-%{_prefix}/lib/mono/4.0/fastcgi-mono-server4.exe
-%{_prefix}/lib/mono/4.0/mod-mono-server4.exe
-%{_prefix}/lib/mono/4.0/xsp4.exe
+%{_prefix}/lib/mono/4.5/Mono.WebServer2.dll
+%{_prefix}/lib/mono/4.5/fastcgi-mono-server4.exe
+%{_prefix}/lib/mono/4.5/mod-mono-server4.exe
+%{_prefix}/lib/mono/4.5/xsp4.exe
%{_prefix}/lib/mono/gac/Mono.WebServer2
%{_prefix}/lib/mono/gac/fastcgi-mono-server2
%{_prefix}/lib/mono/gac/fastcgi-mono-server4
Please sign in to comment.
Something went wrong with that request. Please try again.