Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Beta version 4.0 of BeautifulSoup imports as bs4 instead of BeautifulSoup #66

Closed
ktonon opened this Issue Aug 20, 2011 · 1 comment

Comments

Projects
None yet
2 participants
Contributor

ktonon commented Aug 20, 2011

stable-requirements.txt requires BeautifulSoup>=3.0.8.

I installed via pip and got version 4.0 of this library. Trying to do my first syncdb yields the error

ImportError: No module named BeautifulSoup

Looking at the installed-files.txt in the BeautifulSoup egg-info shows

../bs4/__init__.py
../bs4/dammit.py
...

Launching python and typing import bs4 succeeds.

I changed the first line of stable-requirements.txt to BeautifulSoup==3.2.0 and reinstalled. Everything worked all right.

montylounge added a commit that referenced this issue Sep 24, 2011

Owner

montylounge commented Jan 30, 2012

Resolved.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment