Skip to content
Browse files

MDL-42904: Self enrol. Fix sloppy version numbers

  • Loading branch information...
1 parent cf56938 commit 16d88af2ab3e7dc107fe3febd203aef44052f428 @damyon damyon committed Dec 3, 2013
Showing with 3 additions and 3 deletions.
  1. +2 −2 enrol/self/db/upgrade.php
  2. +1 −1 enrol/self/version.php
View
4 enrol/self/db/upgrade.php
@@ -41,10 +41,10 @@ function xmldb_enrol_self_upgrade($oldversion) {
// Moodle v2.4.0 release upgrade line
// Put any upgrade step following this
- if ($oldversion < 2013112100) {
+ if ($oldversion < 2012112901) {
// Set customint1 (group enrolment key) to 0 if it was not set (null).
$DB->execute("UPDATE {enrol} SET customint1 = 0 WHERE enrol = 'self' AND customint1 IS NULL");
- upgrade_plugin_savepoint(true, 2013112100, 'enrol', 'self');
+ upgrade_plugin_savepoint(true, 2012112901, 'enrol', 'self');
}
return true;
View
2 enrol/self/version.php
@@ -24,7 +24,7 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2013112100; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->version = 2012112901; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2012112900; // Requires this Moodle version
$plugin->component = 'enrol_self'; // Full name of the plugin (used for diagnostics)
$plugin->cron = 600;

0 comments on commit 16d88af

Please sign in to comment.
Something went wrong with that request. Please try again.