Permalink
Browse files

MDL-27121 fix incorrect check_moodle_environment() version parameter

This prevents Moodle 2.0 from using environment info for 2.1 in the installer and CLI upgrade.
  • Loading branch information...
skodak committed Apr 9, 2011
1 parent 6b14adf commit 1c71748dd1c0a84340b68e2bc482b698df9883bb
Showing with 3 additions and 3 deletions.
  1. +1 −1 admin/cli/upgrade.php
  2. +1 −1 admin/index.php
  3. +1 −1 lib/installlib.php
View
@@ -94,7 +94,7 @@
$newversion = "$release ($version)";
// test environment first
-if (!check_moodle_environment($version, $environment_results, false, ENV_SELECT_RELEASE)) {
+if (!check_moodle_environment(normalize_version($release), $environment_results, false, ENV_SELECT_RELEASE)) {
$errors = environment_get_errors($environment_results);
cli_heading(get_string('environment', 'admin'));
foreach ($errors as $error) {
View
@@ -153,7 +153,7 @@
echo $OUTPUT->box($releasenoteslink, 'generalbox releasenoteslink');
require_once($CFG->libdir.'/environmentlib.php');
- if (!check_moodle_environment($release, $environment_results, true, ENV_SELECT_RELEASE)) {
+ if (!check_moodle_environment(normalize_version($release), $environment_results, true, ENV_SELECT_RELEASE)) {
print_upgrade_reload("index.php?agreelicense=1&lang=$CFG->lang");
} else {
echo $OUTPUT->notification(get_string('environmentok', 'admin'), 'notifysuccess');
View
@@ -529,7 +529,7 @@ function install_cli_database(array $options, $interactive) {
}
// test environment first
- if (!check_moodle_environment($version, $environment_results, false, ENV_SELECT_RELEASE)) {
+ if (!check_moodle_environment(normalize_version($release), $environment_results, false, ENV_SELECT_RELEASE)) {
$errors = environment_get_errors($environment_results);
cli_heading(get_string('environment', 'admin'));
foreach ($errors as $error) {

0 comments on commit 1c71748

Please sign in to comment.