Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Deprecating old "upgrade" files. MDL-7214

  • Loading branch information...
commit 3c5f492e9dee0c407204e78efc62c368dcec861a 1 parent 1301de5
stronk7 authored
Showing with 628 additions and 493 deletions.
  1. +5 −15 backup/db/mysql.php
  2. +6 −16 backup/db/postgres7.php
  3. +5 −15 blocks/activity_modules/db/mysql.php
  4. +6 −15 blocks/activity_modules/db/postgres7.php
  5. +6 −15 blocks/admin/db/mysql.php
  6. +6 −15 blocks/admin/db/postgres7.php
  7. +6 −15 blocks/calendar_month/db/mysql.php
  8. +6 −15 blocks/calendar_month/db/postgres7.php
  9. +6 −15 blocks/calendar_upcoming/db/mysql.php
  10. +6 −15 blocks/calendar_upcoming/db/postgres7.php
  11. +6 −15 blocks/course_list/db/mysql.php
  12. +6 −15 blocks/course_list/db/postgres7.php
  13. +6 −15 blocks/course_summary/db/mysql.php
  14. +6 −15 blocks/course_summary/db/postgres7.php
  15. +6 −15 blocks/db/mysql.php
  16. +6 −15 blocks/db/postgres7.php
  17. +6 −15 blocks/news_items/db/mysql.php
  18. +6 −15 blocks/news_items/db/postgres7.php
  19. +6 −15 blocks/online_users/db/mysql.php
  20. +6 −15 blocks/online_users/db/postgres7.php
  21. +6 −15 blocks/participants/db/mysql.php
  22. +6 −15 blocks/participants/db/postgres7.php
  23. +6 −15 blocks/recent_activity/db/mysql.php
  24. +6 −15 blocks/recent_activity/db/postgres7.php
  25. +8 −1 blocks/rss_client/db/mysql.php
  26. +9 −2 blocks/rss_client/db/postgres7.php
  27. +6 −15 blocks/search/db/mysql.php
  28. +6 −15 blocks/search/db/postgres7.php
  29. +6 −15 blocks/search_forums/db/mysql.php
  30. +6 −15 blocks/search_forums/db/postgres7.php
  31. +5 −15 blocks/section_links/db/mysql.php
  32. +6 −15 blocks/section_links/db/postgres7.php
  33. +6 −15 blocks/social_activities/db/mysql.php
  34. +6 −15 blocks/social_activities/db/postgres7.php
  35. +7 −0 enrol/authorize/db/mysql.php
  36. +7 −0 enrol/authorize/db/postgres7.php
  37. +7 −0 enrol/paypal/db/mysql.php
  38. +7 −0 enrol/paypal/db/postgres7.php
  39. +7 −0 mod/assignment/db/mysql.php
  40. +7 −0 mod/assignment/db/postgres7.php
  41. +8 −1 mod/chat/db/mysql.php
  42. +7 −0 mod/chat/db/postgres7.php
  43. +8 −0 mod/choice/db/mysql.php
  44. +8 −0 mod/choice/db/postgres7.php
  45. +8 −1 mod/data/db/mysql.php
  46. +8 −1 mod/data/db/postgres7.php
  47. +7 −0 mod/exercise/db/mysql.php
  48. +8 −1 mod/exercise/db/postgres7.php
  49. +8 −1 mod/forum/db/mysql.php
  50. +8 −1 mod/forum/db/postgres7.php
  51. +8 −0 mod/hotpot/db/mysql.php
  52. +8 −0 mod/hotpot/db/postgres7.php
  53. +7 −0 mod/journal/db/mysql.php
  54. +7 −0 mod/journal/db/postgres7.php
  55. +7 −0 mod/label/db/mysql.php
  56. +7 −0 mod/label/db/postgres7.php
  57. +7 −0 mod/lams/db/mysql.php
  58. +7 −0 mod/lams/db/postgres7.php
  59. +8 −1 mod/lesson/db/mysql.php
  60. +7 −0 mod/lesson/db/postgres7.php
  61. +7 −0 mod/quiz/db/mysql.php
  62. +7 −0 mod/quiz/db/postgres7.php
  63. +7 −0 mod/resource/db/mysql.php
  64. +7 −0 mod/resource/db/postgres7.php
  65. +7 −0 mod/scorm/db/mysql.php
  66. +7 −0 mod/scorm/db/postgres7.php
  67. +7 −0 mod/survey/db/mysql.php
  68. +8 −0 mod/survey/db/postgres7.php
  69. +8 −0 mod/wiki/db/mysql.php
  70. +7 −0 mod/wiki/db/postgres7.php
  71. +7 −0 mod/workshop/db/mysql.php
  72. +7 −0 mod/workshop/db/postgres7.php
  73. +7 −0 question/type/calculated/db/mysql.php
  74. +7 −0 question/type/calculated/db/postgres7.php
  75. +7 −0 question/type/essay/db/mysql.php
  76. +7 −0 question/type/essay/db/postgres7.php
  77. +7 −0 question/type/match/db/mysql.php
  78. +7 −0 question/type/match/db/postgres7.php
  79. +7 −0 question/type/multianswer/db/mysql.php
  80. +7 −0 question/type/multianswer/db/postgres7.php
  81. +8 −1 question/type/multichoice/db/mysql.php
  82. +8 −1 question/type/multichoice/db/postgres7.php
  83. +7 −0 question/type/numerical/db/mysql.php
  84. +7 −0 question/type/numerical/db/postgres7.php
  85. +8 −0 question/type/randomsamatch/db/mysql.php
  86. +7 −0 question/type/randomsamatch/db/postgres7.php
  87. +7 −0 question/type/rqp/db/mysql.php
  88. +7 −0 question/type/rqp/db/postgres7.php
  89. +7 −0 question/type/shortanswer/db/mysql.php
  90. +7 −0 question/type/shortanswer/db/postgres7.php
  91. +7 −0 question/type/truefalse/db/mysql.php
  92. +7 −0 question/type/truefalse/db/postgres7.php
View
20 backup/db/mysql.php
@@ -1,20 +1,9 @@
<?php //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// backup/restore utility.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -164,6 +153,7 @@ function backup_upgrade($oldversion=0) {
table_column('backup_ids','info','info','mediumtext','','','','not null');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
//Finally, return result
return $result;
View
22 backup/db/postgres7.php
@@ -1,21 +1,9 @@
<?php //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// backup/restore utility.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
-//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
function backup_upgrade($oldversion=0) {
@@ -61,6 +49,8 @@ function backup_upgrade($oldversion=0) {
table_column('backup_courses', 'nextstarttime', 'nextstarttime', 'integer', '', '', '0');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
View
20 blocks/activity_modules/db/mysql.php
@@ -1,20 +1,8 @@
<?PHP //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +16,8 @@ function activity_modules_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/activity_modules/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function activity_modules_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/admin/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function admin_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/admin/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function admin_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/calendar_month/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function calendar_month_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/calendar_month/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function calendar_month_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/calendar_upcoming/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function calendar_upcoming_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/calendar_upcoming/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function calendar_upcoming_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/course_list/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function course_list_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/course_list/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function course_list_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/course_summary/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function course_summary_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/course_summary/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function course_summary_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -161,6 +150,8 @@ function blocks_upgrade($oldversion=0) {
modify_database('','ALTER TABLE prefix_block_pinned ADD INDEX pagetype (pagetype);');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -163,6 +152,8 @@ function blocks_upgrade($oldversion=0) {
modify_database('','CREATE INDEX prefix_block_pinned_pagetype_idx ON prefix_block_pinned (pagetype);');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/news_items/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function news_items_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/news_items/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function news_items_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/online_users/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function online_users_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/online_users/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function online_users_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/participants/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function participants_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/participants/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function participants_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/recent_activity/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function recent_activity_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/recent_activity/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function recent_activity_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
9 blocks/rss_client/db/mysql.php
@@ -1,5 +1,10 @@
<?php //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function rss_client_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -130,7 +135,9 @@ function rss_client_upgrade($oldversion) {
}
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
-?>
+?>
View
11 blocks/rss_client/db/postgres7.php
@@ -1,5 +1,10 @@
<?php //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function rss_client_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -131,8 +136,10 @@ function rss_client_upgrade($oldversion) {
}
}
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
-?>
+?>
View
21 blocks/search/db/mysql.php
@@ -1,20 +1,9 @@
<?php
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function search_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/search/db/postgres7.php
@@ -1,20 +1,9 @@
<?php
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to pgsql
@@ -28,6 +17,8 @@ function search_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/search_forums/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function search_forums_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/search_forums/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function search_forums_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
20 blocks/section_links/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -27,6 +16,7 @@ function section_links_upgrade($oldversion=0) {
if ($oldversion < 2004050500 and $result) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
//Finally, return result
return $result;
View
21 blocks/section_links/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function section_links_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/social_activities/db/mysql.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to MySQL
@@ -28,6 +17,8 @@ function social_activities_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
21 blocks/social_activities/db/postgres7.php
@@ -1,20 +1,9 @@
<?PHP //$Id$
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
//
-// This file keeps track of upgrades to Moodle's
-// blocks system.
-//
-// Sometimes, changes between versions involve
-// alterations to database structures and other
-// major things that may break installations.
-//
-// The upgrade function in this file will attempt
-// to perform all the necessary actions to upgrade
-// your older installtion to the current version.
-//
-// If there's something it cannot do itself, it
-// will tell you what you need to do.
-//
-// Versions are defined by backup_version.php
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
//
// This file is tailored to PostgreSQL
@@ -28,6 +17,8 @@ function social_activities_upgrade($oldversion=0) {
$result = true; //Nothing to do
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
//Finally, return result
return $result;
}
View
7 enrol/authorize/db/mysql.php
@@ -1,5 +1,10 @@
<?php //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
// MySQL commands for upgrading this enrolment module
function enrol_authorize_upgrade($oldversion=0) {
@@ -132,6 +137,8 @@ function enrol_authorize_upgrade($oldversion=0) {
execute_sql("ALTER TABLE `{$CFG->prefix}enrol_authorize` ADD paymentmethod enum('cc', 'echeck') NOT NULL default 'cc' AFTER `id`", true);
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $result;
}
View
7 enrol/authorize/db/postgres7.php
@@ -1,5 +1,10 @@
<?php //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
// PostgreSQL commands for upgrading this enrolment module
function enrol_authorize_upgrade($oldversion=0) {
@@ -144,6 +149,8 @@ function enrol_authorize_upgrade($oldversion=0) {
execute_sql("ALTER TABLE {$CFG->prefix}enrol_authorize ADD CONSTRAINT enroauth_pay_ck CHECK (paymentmethod IN ('cc', 'echeck'))", true);
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $result;
}
View
7 enrol/paypal/db/mysql.php
@@ -1,5 +1,10 @@
<?PHP //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
// MySQL commands for upgrading this enrolment module
function enrol_paypal_upgrade($oldversion=0) {
@@ -8,6 +13,8 @@ function enrol_paypal_upgrade($oldversion=0) {
$result = true;
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $result;
}
View
7 enrol/paypal/db/postgres7.php
@@ -1,5 +1,10 @@
<?PHP //$Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
// PostgreSQL commands for upgrading this enrolment module
function enrol_paypal_upgrade($oldversion=0) {
@@ -8,6 +13,8 @@ function enrol_paypal_upgrade($oldversion=0) {
$result = true;
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $result;
}
View
7 mod/assignment/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function assignment_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -168,6 +173,8 @@ function assignment_upgrade($oldversion) {
include_once("$CFG->dirroot/mod/assignment/lib.php");
assignment_upgrade_submodules();
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/assignment/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function assignment_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -175,6 +180,8 @@ function assignment_upgrade($oldversion) {
include_once("$CFG->dirroot/mod/assignment/lib.php");
assignment_upgrade_submodules();
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/chat/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function chat_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -57,7 +62,9 @@ function chat_upgrade($oldversion) {
table_column('chat_users', '', 'course', 'integer', '10', 'unsigned', '0', 'not null', '');
table_column('chat_users', '', 'lang' , 'varchar', '10', '' , '' , 'not null', '');
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/chat/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function chat_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -52,6 +57,8 @@ function chat_upgrade($oldversion) {
modify_database('','ALTER TABLE prefix_chat_users ALTER lang SET NOT NULL');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
8 mod/choice/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function choice_upgrade($oldversion) {
global $CFG;
@@ -122,6 +127,9 @@ function choice_upgrade($oldversion) {
if ($oldversion < 2006020900) { //rename release column to showanswers - Release is now reserved word in mySql
table_column('choice', '`release`', 'showresults', 'TINYINT', '2', 'unsigned', 0, 'not null');
}
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
8 mod/choice/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function choice_upgrade($oldversion) {
global $CFG;
@@ -102,6 +107,9 @@ function choice_upgrade($oldversion) {
if ($oldversion < 2006020900) { //rename release column to showanswers - Release is now reserved word in mySql
table_column('choice', 'release', 'showresults', 'TINYINT', '2', 'unsigned', 0, 'not null');
}
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/data/db/mysql.php
@@ -1,5 +1,10 @@
<?php
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function data_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -136,7 +141,9 @@ function data_upgrade($oldversion) {
execute_sql("ALTER TABLE {$CFG->prefix}data_content CHANGE content3 content3 longtext NULL AFTER content2");
execute_sql("ALTER TABLE {$CFG->prefix}data_content CHANGE content4 content4 longtext NULL AFTER content3");
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/data/db/postgres7.php
@@ -1,5 +1,10 @@
<?php
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function data_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -265,7 +270,9 @@ function data_upgrade($oldversion) {
execute_sql("ALTER TABLE {$CFG->prefix}data_content ALTER COLUMN content4 DROP NOT NULL");
execute_sql("ALTER TABLE {$CFG->prefix}data_content ALTER COLUMN content4 DROP DEFAULT");
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/exercise/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function exercise_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -56,6 +61,8 @@ function exercise_upgrade($oldversion) {
modify_database('','ALTER TABLE prefix_exercise_grades ADD INDEX exerciseid (exerciseid);');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/exercise/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function exercise_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -43,7 +48,9 @@ function exercise_upgrade($oldversion) {
modify_database('','CREATE INDEX prefix_exercise_rubrics_exerciseid_idx ON prefix_exercise_rubrics (exerciseid);');
modify_database('','CREATE INDEX prefix_exercise_grades_exerciseid_idx ON prefix_exercise_grades (exerciseid);');
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/forum/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function forum_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -282,7 +287,9 @@ function forum_upgrade($oldversion) {
execute_sql($sql);
}
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/forum/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function forum_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -232,9 +237,11 @@ function forum_upgrade($oldversion) {
}
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
-?>
+?>
View
8 mod/hotpot/db/mysql.php
@@ -1,4 +1,10 @@
<?PHP
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function hotpot_upgrade($oldversion) {
global $CFG;
$ok = true;
@@ -57,6 +63,8 @@ function hotpot_upgrade($oldversion) {
$ok = $ok && hotpot_update_to_v2_2();
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $ok;
}
?>
View
8 mod/hotpot/db/postgres7.php
@@ -1,4 +1,10 @@
<?PHP
+
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function hotpot_upgrade($oldversion) {
global $CFG;
$ok = true;
@@ -59,6 +65,8 @@ function hotpot_upgrade($oldversion) {
$ok = $ok && hotpot_update_to_v2_2();
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $ok;
}
?>
View
7 mod/journal/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function journal_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -81,6 +86,8 @@ function journal_upgrade($oldversion) {
table_column('journal_entries', 'comment', 'entrycomment', 'text', '', '', '');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $result;
}
View
7 mod/journal/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function journal_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -56,5 +61,7 @@ function journal_upgrade($oldversion) {
table_column('journal_entries', 'comment', 'entrycomment', 'text', '', '', '');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $result;
}
View
7 mod/label/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function label_upgrade($oldversion) {
/// This function does anything necessary to upgrade
@@ -21,6 +26,8 @@ function label_upgrade($oldversion) {
modify_database('','ALTER TABLE prefix_label ADD INDEX course (course);');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/label/db/postgres7.php
@@ -1,5 +1,10 @@
<?php
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function label_upgrade($oldversion) {
/// This function does anything necessary to upgrade
@@ -34,6 +39,8 @@ function label_upgrade($oldversion) {
modify_database('','CREATE INDEX prefix_label_course_idx ON prefix_label (course);');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/lams/db/mysql.php
@@ -1,5 +1,10 @@
<?PHP
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function lams_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -12,6 +17,8 @@ function lams_upgrade($oldversion) {
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/lams/db/postgres7.php
@@ -1,5 +1,10 @@
<?PHP
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function lams_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -12,6 +17,8 @@ function lams_upgrade($oldversion) {
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
9 mod/lesson/db/mysql.php
@@ -1,5 +1,10 @@
<?PHP
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function lesson_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -235,7 +240,9 @@ function lesson_upgrade($oldversion) {
table_column('lesson', '', 'feedback', 'int', '3', 'unsigned', '1', 'not null', 'nextpagedefault');
table_column('lesson_default', '', 'feedback', 'int', '3', 'unsigned', '1', 'not null', 'nextpagedefault');
}
-
+
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/lesson/db/postgres7.php
@@ -1,5 +1,10 @@
<?PHP
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function lesson_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -358,6 +363,8 @@ function lesson_upgrade($oldversion) {
table_column('lesson_default', '', 'feedback', 'int', '3', 'unsigned', '1', 'not null', 'nextpagedefault');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/quiz/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function quiz_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -1144,6 +1149,8 @@ function quiz_upgrade($oldversion) {
$success = $success && table_column('question', 'commentarytext', 'generalfeedback', 'text', '', '', '');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $success;
}
View
7 mod/quiz/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function quiz_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -1466,6 +1471,8 @@ function quiz_upgrade($oldversion) {
$success = $success && table_column('question', 'commentarytext', 'generalfeedback', 'text', '', '', '');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return $success;
}
View
7 mod/resource/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function resource_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -70,6 +75,8 @@ function resource_upgrade($oldversion) {
table_column('resource','reference','reference','varchar','255','','','not null');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/resource/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function resource_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -61,6 +66,8 @@ function resource_upgrade($oldversion) {
$wtm->update( 'resource','alltext','options' );
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
7 mod/scorm/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function scorm_upgrade($oldversion) {
/// This function does anything necessary to upgrade
/// older versions to match current functionality
@@ -226,6 +231,8 @@ function scorm_upgrade($oldversion) {
execute_sql("INSERT INTO {$CFG->prefix}log_display (module, action, mtable, field) VALUES ('scorm', 'review', 'scorm', 'name');", false);
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
?>
View
7 mod/scorm/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function scorm_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -249,6 +254,8 @@ function scorm_upgrade($oldversion) {
execute_sql("INSERT INTO {$CFG->prefix}log_display (module, action, mtable, field) VALUES ('scorm', 'review', 'scorm', 'name');", false);
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
?>
View
7 mod/survey/db/mysql.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function survey_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality
@@ -214,6 +219,8 @@ function survey_upgrade($oldversion) {
table_column('survey_questions','intro','intro','varchar','50','','','not null');
}
+ ////// DO NOT ADD NEW THINGS HERE!! USE upgrade.php and the lib/ddllib.php functions.
+
return true;
}
View
8 mod/survey/db/postgres7.php
@@ -1,5 +1,10 @@
<?php // $Id$
+// THIS FILE IS DEPRECATED! PLEASE DO NOT MAKE CHANGES TO IT!
+//
+// IT IS USED ONLY FOR UPGRADES FROM BEFORE MOODLE 1.7, ALL
+// LATER CHANGES SHOULD USE upgrade.php IN THIS DIRECTORY.
+
function survey_upgrade($oldversion) {
// This function does anything necessary to upgrade
// older versions to match current functionality