Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Merge branch 'MDL-38557_23' of git://github.com/timhunt/moodle into M…

…OODLE_23_STABLE
  • Loading branch information...
commit 4984697c122150d2c78ef0c4b171381ca0827e17 2 parents e721f2d + 23149b2
Eloy Lafuente (stronk7) stronk7 authored
1  mod/quiz/db/install.php
@@ -46,5 +46,6 @@ function xmldb_quiz_install() {
46 46 $record = new stdClass();
47 47 $record->name = 'grading';
48 48 $record->displayorder = '6000';
  49 + $record->capability = 'mod/quiz:grade';
49 50 $DB->insert_record('quiz_reports', $record);
50 51 }
8 mod/quiz/db/upgrade.php
@@ -392,6 +392,14 @@ function xmldb_quiz_upgrade($oldversion) {
392 392 upgrade_mod_savepoint(true, 2012061704, 'quiz');
393 393 }
394 394
  395 + if ($oldversion < 2012061705) {
  396 + // Quiz manual grading UI should be controlled by mod/quiz:grade, not :viewreports.
  397 + $DB->set_field('quiz_reports', 'capability', 'mod/quiz:grade', array('name' => 'grading'));
  398 +
  399 + // Mod quiz savepoint reached.
  400 + upgrade_mod_savepoint(true, 2012061705, 'quiz');
  401 + }
  402 +
395 403 return true;
396 404 }
397 405
2  mod/quiz/version.php
@@ -25,7 +25,7 @@
25 25
26 26 defined('MOODLE_INTERNAL') || die();
27 27
28   -$module->version = 2012061704; // The current module version (Date: YYYYMMDDXX).
  28 +$module->version = 2012061705; // The current module version (Date: YYYYMMDDXX).
29 29 $module->requires = 2012061700; // Requires this Moodle version.
30 30 $module->component = 'mod_quiz'; // Full name of the plugin (used for diagnostics).
31 31 $module->cron = 60;

0 comments on commit 4984697

Please sign in to comment.
Something went wrong with that request. Please try again.