Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge branch 'MDL-30007' of git://github.com/stronk7/moodle

  • Loading branch information...
commit 6416c6c25b56427c1157c21f5d61e04d663aa83f 2 parents 0f4c606 + 59e6df2
@samhemelryk samhemelryk authored
Showing with 3,243 additions and 471 deletions.
  1. +1 −1  admin/tool/bloglevelupgrade/version.php
  2. +1 −1  admin/tool/capability/version.php
  3. +2 −0  admin/tool/customlang/version.php
  4. +1 −1  admin/tool/dbtransfer/version.php
  5. +1 −1  admin/tool/generator/version.php
  6. +1 −1  admin/tool/health/version.php
  7. +1 −1  admin/tool/innodb/version.php
  8. +1 −1  admin/tool/langimport/version.php
  9. +2 −1  admin/tool/multilangupgrade/version.php
  10. +1 −1  admin/tool/profiling/version.php
  11. +1 −1  admin/tool/qeupgradehelper/version.php
  12. +1 −1  admin/tool/replace/version.php
  13. +1 −1  admin/tool/spamcleaner/version.php
  14. +1 −1  admin/tool/timezoneimport/version.php
  15. +2 −0  admin/tool/unittest/version.php
  16. +2 −1  admin/tool/unsuproles/version.php
  17. +2 −1  admin/tool/uploaduser/version.php
  18. +2 −1  admin/tool/xmldb/version.php
  19. +30 −1 auth/cas/version.php
  20. +28 −1 auth/db/version.php
  21. +30 −0 auth/email/version.php
  22. +28 −1 auth/fc/version.php
  23. +28 −1 auth/imap/version.php
  24. +29 −1 auth/ldap/version.php
  25. +3 −2 auth/manual/version.php
  26. +28 −1 auth/mnet/version.php
  27. +28 −1 auth/nntp/version.php
  28. +30 −0 auth/nologin/version.php
  29. +30 −0 auth/none/version.php
  30. +28 −1 auth/pam/version.php
  31. +28 −1 auth/pop3/version.php
  32. +28 −1 auth/radius/version.php
  33. +29 −1 auth/shibboleth/version.php
  34. +30 −0 auth/webservice/version.php
  35. +14 −2 blocks/activity_modules/version.php
  36. +14 −2 blocks/admin_bookmarks/version.php
  37. +14 −2 blocks/blog_menu/version.php
  38. +14 −2 blocks/blog_recent/version.php
  39. +14 −2 blocks/blog_tags/version.php
  40. +14 −2 blocks/calendar_month/version.php
  41. +14 −2 blocks/calendar_upcoming/version.php
  42. +14 −2 blocks/comments/version.php
  43. +14 −2 blocks/community/version.php
  44. +2 −1  blocks/completionstatus/version.php
  45. +14 −2 blocks/course_list/version.php
  46. +14 −2 blocks/course_overview/version.php
  47. +14 −2 blocks/course_summary/version.php
  48. +14 −2 blocks/feedback/version.php
  49. +14 −2 blocks/glossary_random/version.php
  50. +14 −2 blocks/html/version.php
  51. +14 −2 blocks/login/version.php
  52. +14 −2 blocks/mentees/version.php
  53. +14 −2 blocks/messages/version.php
  54. +11 −3 blocks/mnet_hosts/version.php
  55. +3 −1 blocks/myprofile/version.php
  56. +14 −2 blocks/navigation/version.php
  57. +14 −2 blocks/news_items/version.php
  58. +14 −2 blocks/online_users/version.php
  59. +14 −2 blocks/participants/version.php
  60. +14 −2 blocks/private_files/version.php
  61. +3 −6 blocks/quiz_results/version.php
  62. +14 −2 blocks/recent_activity/version.php
  63. +15 −3 blocks/rss_client/version.php
  64. +14 −2 blocks/search_forums/version.php
  65. +14 −2 blocks/section_links/version.php
  66. +14 −2 blocks/selfcompletion/version.php
  67. +14 −2 blocks/settings/version.php
  68. +14 −2 blocks/site_main_menu/version.php
  69. +14 −2 blocks/social_activities/version.php
  70. +14 −2 blocks/tag_flickr/version.php
  71. +14 −2 blocks/tag_youtube/version.php
  72. +14 −3 blocks/tags/version.php
  73. +4 −3 enrol/authorize/version.php
  74. +4 −3 enrol/category/version.php
  75. +4 −3 enrol/cohort/version.php
  76. +3 −2 enrol/database/version.php
  77. +4 −3 enrol/flatfile/version.php
  78. +3 −2 enrol/guest/version.php
  79. +4 −3 enrol/imsenterprise/version.php
  80. +3 −2 enrol/ldap/version.php
  81. +3 −2 enrol/manual/version.php
  82. +4 −3 enrol/meta/version.php
  83. +3 −2 enrol/mnet/version.php
  84. +3 −2 enrol/paypal/version.php
  85. +4 −3 enrol/self/version.php
  86. +30 −0 filter/activitynames/version.php
  87. +30 −0 filter/algebra/version.php
  88. +30 −0 filter/censor/version.php
  89. +30 −0 filter/emailprotect/vesion.php
  90. +5 −2 filter/emoticon/version.php
  91. +3 −2 filter/mediaplugin/version.php
  92. +30 −0 filter/multilang/version.php
  93. +3 −2 filter/tex/version.php
  94. +30 −0 filter/tidy/version.php
  95. +5 −2 filter/urltolink/version.php
  96. +12 −3 grade/export/ods/version.php
  97. +12 −3 grade/export/txt/version.php
  98. +12 −3 grade/export/xls/version.php
  99. +12 −3 grade/export/xml/version.php
  100. +12 −3 grade/import/csv/version.php
  101. +12 −3 grade/import/xml/version.php
  102. +12 −3 grade/report/grader/version.php
  103. +12 −3 grade/report/outcomes/version.php
  104. +12 −3 grade/report/overview/version.php
  105. +12 −3 grade/report/user/version.php
  106. +3 −3 lib/editor/textarea/version.php
  107. +4 −4 lib/editor/tinymce/version.php
  108. +22 −30 message/output/email/version.php
  109. +22 −29 message/output/jabber/version.php
  110. +22 −29 message/output/popup/version.php
  111. +5 −2 mnet/service/enrol/version.php
  112. +26 −0 mod/assignment/type/offline/lang/en/assignment_offline.php
  113. +30 −0 mod/assignment/type/offline/version.php
  114. +26 −0 mod/assignment/type/online/lang/en/assignment_online.php
  115. +26 −7 mod/assignment/type/online/version.php
  116. +26 −0 mod/assignment/type/upload/lang/en/assignment_upload.php
  117. +30 −0 mod/assignment/type/upload/version.php
  118. +26 −0 mod/assignment/type/uploadsingle/lang/en/assignment_uploadsingle.php
  119. +30 −0 mod/assignment/type/uploadsingle/version.php
  120. +27 −8 mod/assignment/version.php
  121. +28 −7 mod/chat/version.php
  122. +27 −8 mod/choice/version.php
  123. +27 −0 mod/data/field/checkbox/lang/en/datafield_checkbox.php
  124. +28 −0 mod/data/field/checkbox/version.php
  125. +27 −0 mod/data/field/date/lang/en/datafield_date.php
  126. +28 −0 mod/data/field/date/version.php
  127. +27 −0 mod/data/field/file/lang/en/datafield_file.php
  128. +28 −0 mod/data/field/file/version.php
  129. +27 −0 mod/data/field/latlong/lang/en/datafield_latlong.php
  130. +28 −0 mod/data/field/latlong/version.php
  131. +27 −0 mod/data/field/menu/lang/en/datafield_menu.php
  132. +28 −0 mod/data/field/menu/version.php
  133. +27 −0 mod/data/field/multimenu/lang/en/datafield_multimenu.php
  134. +28 −0 mod/data/field/multimenu/version.php
  135. +27 −0 mod/data/field/number/lang/en/datafield_number.php
  136. +28 −0 mod/data/field/number/version.php
  137. +27 −0 mod/data/field/picture/lang/en/datafield_picture.php
  138. +28 −0 mod/data/field/picture/version.php
  139. +27 −0 mod/data/field/radiobutton/lang/en/datafield_radiobutton.php
  140. +28 −0 mod/data/field/radiobutton/version.php
  141. +27 −0 mod/data/field/text/lang/en/datafield_text.php
  142. +28 −0 mod/data/field/text/version.php
  143. +27 −0 mod/data/field/textarea/lang/en/datafield_textarea.php
  144. +28 −0 mod/data/field/textarea/version.php
  145. +27 −0 mod/data/field/url/lang/en/datafield_url.php
  146. +28 −0 mod/data/field/url/version.php
  147. +1 −0  mod/data/preset/imagegallery/lang/en/datapreset_imagegallery.php
  148. +28 −0 mod/data/preset/imagegallery/version.php
  149. +5 −4 mod/data/version.php
  150. +11 −9 mod/feedback/version.php
  151. +4 −5 mod/folder/version.php
  152. +4 −5 mod/forum/version.php
  153. +4 −3 mod/glossary/version.php
  154. +4 −5 mod/imscp/version.php
  155. +5 −7 mod/label/version.php
  156. +7 −10 mod/lesson/version.php
  157. +3 −3 mod/lti/version.php
  158. +5 −6 mod/page/version.php
  159. +1 −0  mod/quiz/report/grading/version.php
  160. +1 −0  mod/quiz/report/overview/version.php
  161. +2 −0  mod/quiz/report/responses/version.php
  162. +1 −0  mod/quiz/report/statistics/version.php
  163. +4 −3 mod/quiz/version.php
  164. +4 −5 mod/resource/version.php
  165. +6 −3 mod/scorm/version.php
  166. +27 −8 mod/survey/version.php
  167. +5 −6 mod/url/version.php
  168. +8 −6 mod/wiki/version.php
  169. +30 −0 mod/workshop/allocation/manual/version.php
  170. +30 −0 mod/workshop/allocation/random/version.php
  171. +1 −1  mod/workshop/eval/best/version.php
  172. +1 −0  mod/workshop/form/accumulative/version.php
  173. +1 −0  mod/workshop/form/comments/version.php
  174. +1 −0  mod/workshop/form/numerrors/version.php
  175. +1 −0  mod/workshop/form/rubric/version.php
  176. +4 −7 mod/workshop/version.php
  177. +26 −3 portfolio/boxnet/version.php
  178. +26 −3 portfolio/download/version.php
  179. +26 −3 portfolio/flickr/version.php
  180. +27 −3 portfolio/googledocs/version.php
  181. +10 −10 portfolio/mahara/version.php
  182. +26 −3 portfolio/picasa/version.php
  183. +15 −2 repository/alfresco/version.php
  184. +15 −2 repository/boxnet/version.php
  185. +15 −2 repository/coursefiles/version.php
  186. +15 −2 repository/dropbox/version.php
  187. +15 −2 repository/filesystem/version.php
  188. +15 −2 repository/flickr/version.php
  189. +15 −2 repository/flickr_public/version.php
  190. +14 −2 repository/googledocs/version.php
  191. +15 −2 repository/local/version.php
  192. +15 −2 repository/merlot/version.php
  193. +15 −2 repository/picasa/version.php
  194. +15 −2 repository/recent/version.php
  195. +15 −2 repository/s3/version.php
  196. +15 −2 repository/upload/version.php
  197. +15 −2 repository/url/version.php
  198. +15 −2 repository/user/version.php
  199. +15 −2 repository/webdav/version.php
  200. +15 −2 repository/wikimedia/version.php
  201. +15 −2 repository/youtube/version.php
  202. +28 −0 user/profile/field/checkbox/version.php
  203. +28 −0 user/profile/field/datetime/version.php
  204. +28 −0 user/profile/field/menu/version.php
  205. +28 −0 user/profile/field/text/version.php
  206. +28 −0 user/profile/field/textarea/version.php
  207. +28 −1 webservice/amf/version.php
  208. +28 −1 webservice/rest/version.php
  209. +28 −1 webservice/soap/version.php
  210. +28 −1 webservice/xmlrpc/version.php
View
2  admin/tool/bloglevelupgrade/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/capability/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/customlang/version.php
@@ -15,6 +15,8 @@
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
/**
+ * Version information
+ *
* @package tool
* @subpackage customlang
* @copyright 2010 David Mudrak <david@moodle.com>
View
2  admin/tool/dbtransfer/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/generator/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/health/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/innodb/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/langimport/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
3  admin/tool/multilangupgrade/version.php
@@ -22,7 +22,8 @@
* @copyright 2011 Petr Skoda {@link http://skodak.org}
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/profiling/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/qeupgradehelper/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500;
$plugin->requires = 2011092100;
View
2  admin/tool/replace/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
2  admin/tool/spamcleaner/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500;
$plugin->requires = 2011092100;
View
2  admin/tool/timezoneimport/version.php
@@ -23,7 +23,7 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500;
$plugin->requires = 2011092100;
View
2  admin/tool/unittest/version.php
@@ -23,6 +23,8 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
+defined('MOODLE_INTERNAL') || die();
+
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
$plugin->component = 'tool_unittest'; // Full name of the plugin (used for diagnostics)
View
3  admin/tool/unsuproles/version.php
@@ -22,7 +22,8 @@
* @copyright 2010 Petr Skoda {@link http://skodak.org}
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
3  admin/tool/uploaduser/version.php
@@ -22,7 +22,8 @@
* @copyright 2011 Petr Skoda {@link http://skodak.org}
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
3  admin/tool/xmldb/version.php
@@ -22,7 +22,8 @@
* @copyright 2003 onwards Eloy Lafuente (stronk7) {@link http://stronk7.com}
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-defined('MOODLE_INTERNAL') || die;
+
+defined('MOODLE_INTERNAL') || die();
$plugin->version = 2011092500; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2011092100; // Requires this Moodle version
View
31 auth/cas/version.php
@@ -1,3 +1,32 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010072600;
+/**
+ * Version details
+ *
+ * @package auth
+ * @subpackage cas
+ * @author Martin Dougiamas
+ * @author Jerome GUTIERREZ
+ * @author Iñaky Arenaza
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_cas'; // Full name of the plugin (used for diagnostics)
View
29 auth/db/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version details
+ *
+ * @package auth
+ * @subpackage db
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_db'; // Full name of the plugin (used for diagnostics)
View
30 auth/email/version.php
@@ -0,0 +1,30 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * Version details
+ *
+ * @package auth
+ * @subpackage email
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die;
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_email'; // Full name of the plugin (used for diagnostics)
View
29 auth/fc/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version details
+ *
+ * @package auth
+ * @subpackage fc
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_fc'; // Full name of the plugin (used for diagnostics)
View
29 auth/imap/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version details
+ *
+ * @package auth
+ * @subpackage imap
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_imap'; // Full name of the plugin (used for diagnostics)
View
30 auth/ldap/version.php
@@ -1,3 +1,31 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010072600;
+/**
+ * Version details
+ *
+ * @package auth
+ * @subpackage ldap
+ * @author Martin Dougiamas
+ * @author Iñaky Arenaza
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_ldap'; // Full name of the plugin (used for diagnostics)
View
5 auth/manual/version.php
@@ -25,5 +25,6 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2011022700;
-$plugin->component = 'auth_manual';
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_manual'; // Full name of the plugin (used for diagnostics)
View
29 auth/mnet/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010071300;
+/**
+ * Manual authentication plugin version information
+ *
+ * @package auth
+ * @subpackage mnet
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_mnet'; // Full name of the plugin (used for diagnostics)
View
29 auth/nntp/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage nntp
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_nntp'; // Full name of the plugin (used for diagnostics)
View
30 auth/nologin/version.php
@@ -0,0 +1,30 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage nologin
+ * @copyright 2011 Petr Skoda (http://skodak.org)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_nologin'; // Full name of the plugin (used for diagnostics)
View
30 auth/none/version.php
@@ -0,0 +1,30 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage none
+ * @copyright 2011 Petr Skoda (http://skodak.org)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_none'; // Full name of the plugin (used for diagnostics)
View
29 auth/pam/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage pam
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_pam'; // Full name of the plugin (used for diagnostics)
View
29 auth/pop3/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage pop3
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_pop3'; // Full name of the plugin (used for diagnostics)
View
29 auth/radius/version.php
@@ -1,3 +1,30 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage radius
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_radius'; // Full name of the plugin (used for diagnostics)
View
30 auth/shibboleth/version.php
@@ -1,3 +1,31 @@
<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009112400;
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage shibboleth
+ * @author Martin Dougiamas
+ * @author Lukas Haemmerle
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_shibboleth'; // Full name of the plugin (used for diagnostics)
View
30 auth/webservice/version.php
@@ -0,0 +1,30 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * Version information
+ *
+ * @package auth
+ * @subpackage webservice
+ * @copyright 2011 Petr Skoda (http://skodak.org)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'auth_webservice'; // Full name of the plugin (used for diagnostics)
View
16 blocks/activity_modules/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage activity_modules
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_activity_modules'; // Full name of the plugin (used for diagnostics)
View
16 blocks/admin_bookmarks/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage admin_bookmarks
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_admin_bookmarks'; // Full name of the plugin (used for diagnostics)
View
16 blocks/blog_menu/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009071700;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage blog_menu
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_blog_menu'; // Full name of the plugin (used for diagnostics)
View
16 blocks/blog_recent/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009070900;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage blog_recent
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_blog_recent'; // Full name of the plugin (used for diagnostics)
View
16 blocks/blog_tags/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage blog_tags
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_blog_tags'; // Full name of the plugin (used for diagnostics)
View
16 blocks/calendar_month/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage calendar_moth
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_calendar_month'; // Full name of the plugin (used for diagnostics)
View
16 blocks/calendar_upcoming/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage calendar_upcoming
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_calendar_upcoming'; // Full name of the plugin (used for diagnostics)
View
16 blocks/comments/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009072000;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage comments
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_comments'; // Full name of the plugin (used for diagnostics)
View
16 blocks/community/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010042701;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage community
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_community'; // Full name of the plugin (used for diagnostics)
View
3  blocks/completionstatus/version.php
@@ -26,6 +26,7 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2011110300;
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
$plugin->component = 'block_completionstatus';
$plugin->dependencies = array('report_completion' => 2011110200);
View
16 blocks/course_list/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage course_list
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_course_list'; // Full name of the plugin (used for diagnostics)
View
16 blocks/course_overview/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010021100;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage course_overview
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_course_overview'; // Full name of the plugin (used for diagnostics)
View
16 blocks/course_summary/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage course_summary
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_course_summary'; // Full name of the plugin (used for diagnostics)
View
16 blocks/feedback/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010050200;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage feedback
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_feedback'; // Full name of the plugin (used for diagnostics)
View
16 blocks/glossary_random/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage glossary_random
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_glossary_random'; // Full name of the plugin (used for diagnostics)
View
16 blocks/html/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010071900;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage html
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_html'; // Full name of the plugin (used for diagnostics)
View
16 blocks/login/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage login
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_login'; // Full name of the plugin (used for diagnostics)
View
16 blocks/mentees/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage mentees
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_mentees'; // Full name of the plugin (used for diagnostics)
View
16 blocks/messages/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage messages
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_messages'; // Full name of the plugin (used for diagnostics)
View
14 blocks/mnet_hosts/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -16,7 +15,16 @@
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
/**
- * Network servers block version is defined in this file
+ * Version details
+ *
+ * @package block
+ * @subpackage mnet_hosts
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-$plugin->version = 2010112900;
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_mnet_hosts'; // Full name of the plugin (used for diagnostics)
View
4 blocks/myprofile/version.php
@@ -26,4 +26,6 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2009123100;
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_myprofile'; // Full name of the plugin (used for diagnostics)
View
16 blocks/navigation/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010091400;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage navigation
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_navigation'; // Full name of the plugin (used for diagnostics)
View
16 blocks/news_items/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage news_items
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_news_items'; // Full name of the plugin (used for diagnostics)
View
16 blocks/online_users/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101510;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage online_users
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_online_users'; // Full name of the plugin (used for diagnostics)
View
16 blocks/participants/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage participants
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_participants'; // Full name of the plugin (used for diagnostics)
View
16 blocks/private_files/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010030100;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage private_files
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_private_files'; // Full name of the plugin (used for diagnostics)
View
9 blocks/quiz_results/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -24,10 +23,8 @@
* @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
*/
-
defined('MOODLE_INTERNAL') || die();
-
-$plugin->version = 2011100300;
-$plugin->requires = 2011091600;
-$plugin->component = 'block_quiz_results';
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_quiz_results'; // Full name of the plugin (used for diagnostics)
View
16 blocks/recent_activity/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage recent_activity
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_recent_activity'; // Full name of the plugin (used for diagnostics)
View
18 blocks/rss_client/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,5 +14,18 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009072901;
-$plugin->cron = 300; /// Set min time between cron executions to 300 secs (5 mins)
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage rss_client
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_rss_client'; // Full name of the plugin (used for diagnostics)
+$plugin->cron = 300; // Set min time between cron executions to 300 secs (5 mins)
View
16 blocks/search_forums/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage search_forums
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_search_forums'; // Full name of the plugin (used for diagnostics)
View
16 blocks/section_links/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101511;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage section_links
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_section_links'; // Full name of the plugin (used for diagnostics)
View
16 blocks/selfcompletion/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2009072800;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage selfcompletion
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_selfcompletion'; // Full name of the plugin (used for diagnostics)
View
16 blocks/settings/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010091400;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage settings
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_settings'; // Full name of the plugin (used for diagnostics)
View
16 blocks/site_main_menu/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage site_main_menu
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_site_main_menu'; // Full name of the plugin (used for diagnostics)
View
16 blocks/social_activities/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage social_activities
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_social_activities'; // Full name of the plugin (used for diagnostics)
View
16 blocks/tag_flickr/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage tag_flickr
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_tag_flickr'; // Full name of the plugin (used for diagnostics)
View
16 blocks/tag_youtube/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,4 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2007101509;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage tag_youtube
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_tag_youtube'; // Full name of the plugin (used for diagnostics)
View
17 blocks/tags/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -15,5 +14,17 @@
// You should have received a copy of the GNU General Public License
// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
-$plugin->version = 2010090502;
-$plugin->requires = 2010090501;
+/**
+ * Version details
+ *
+ * @package block
+ * @subpackage tags
+ * @copyright 1999 onwards Martin Dougiamas (http://dougiamas.com)
+ * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'block_tags'; // Full name of the plugin (used for diagnostics)
View
7 enrol/authorize/version.php
@@ -26,6 +26,7 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2010081203;
-$plugin->requires = 2010090501;
-$plugin->cron = 180;
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'enrol_authorize'; // Full name of the plugin (used for diagnostics)
+$plugin->cron = 180;
View
7 enrol/category/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -26,5 +25,7 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2010061500;
-$plugin->cron = 60;
+$plugin->version = 2011112900; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires = 2011112900; // Requires this Moodle version
+$plugin->component = 'enrol_category'; // Full name of the plugin (used for diagnostics)
+$plugin->cron = 60;
View
7 enrol/cohort/version.php
@@ -1,5 +1,4 @@
<?php
-
// This file is part of Moodle - http://moodle.org/
//
// Moodle is free software: you can redistribute it and/or modify
@@ -26,5 +25,7 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2010073100;