Permalink
Browse files

MDL-26469 upgrade: cope with modules that do not set $module->cron.

  • Loading branch information...
timhunt authored and stronk7 committed Jan 11, 2012
1 parent 1893012 commit 7ecee68542304f1011e37f893915ff1bc51b58a5
Showing with 4 additions and 0 deletions.
  1. +4 −0 lib/upgradelib.php
View
@@ -465,6 +465,10 @@ function upgrade_plugins_modules($startcallback, $endcallback, $verbose) {
}
}
+ if (empty($module->cron)) {
+ $module->cron = 0;
+ }
+
// all modules must have en lang pack
if (!is_readable("$fullmod/lang/en/$mod.php")) {
throw new plugin_defective_exception($component, 'Missing mandatory en language pack.');

0 comments on commit 7ecee68

Please sign in to comment.