Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge branch 'w32_MDL-34601_m23_wikischema' of git://github.com/skoda…

…k/moodle into MOODLE_23_STABLE
  • Loading branch information...
commit 9064a9af716e9f9bca9e14f5dfce4bec4bf3fe5b 2 parents 1e77822 + 137bd7a
@stronk7 stronk7 authored
Showing with 22 additions and 1 deletion.
  1. +21 −0 mod/wiki/db/upgrade.php
  2. +1 −1  mod/wiki/version.php
View
21 mod/wiki/db/upgrade.php
@@ -48,6 +48,27 @@ function xmldb_wiki_upgrade($oldversion) {
// Moodle v2.3.0 release upgrade line
// Put any upgrade step following this
+ if ($oldversion < 2012061701) {
+ // Drop all legacy upgrade tables, not used anymore.
+
+ $table = new xmldb_table('wiki_entries_old');
+ if ($dbman->table_exists('wiki_entries_old')) {
+ $dbman->drop_table($table);
+ }
+
+ $table = new xmldb_table('wiki_locks_old');
+ if ($dbman->table_exists('wiki_locks_old')) {
+ $dbman->drop_table($table);
+ }
+
+ $table = new xmldb_table('wiki_pages_old');
+ if ($dbman->table_exists('wiki_pages_old')) {
+ $dbman->drop_table($table);
+ }
+
+ upgrade_plugin_savepoint(true, 2012061701, 'mod', 'wiki');
+ }
+
return true;
}
View
2  mod/wiki/version.php
@@ -33,7 +33,7 @@
defined('MOODLE_INTERNAL') || die();
-$module->version = 2012061700; // The current module version (Date: YYYYMMDDXX)
+$module->version = 2012061701; // The current module version (Date: YYYYMMDDXX)
$module->requires = 2012061700; // Requires this Moodle version
$module->component = 'mod_wiki'; // Full name of the plugin (used for diagnostics)
$module->cron = 0;
Please sign in to comment.
Something went wrong with that request. Please try again.