Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

MDL-31938: fix syntax error in db upgrade & update plugin version

Also correct language class name.
  • Loading branch information...
commit 9953966213a9b3cb13390d7da232a69495848eaa 1 parent 02a9e4a
@thijskh thijskh authored danpoltawski committed
View
3  auth/cas/db/upgrade.php
@@ -37,10 +37,11 @@ function xmldb_auth_cas_upgrade($oldversion) {
set_config('start_tls', 0, 'auth/cas');
}
upgrade_plugin_savepoint(true, 2013052100, 'auth', 'cas');
+ }
if ($oldversion < 2013091700) {
// The value of the phpCAS language constants has changed from
- // 'langname' to 'CAS_Languages_langname'.
+ // 'langname' to 'CAS_Languages_Langname'.
if ($cas_language = get_config('auth/cas', 'language')) {
set_config('language', 'CAS_Languages_'.ucfirst($cas_language), 'auth/cas');
}
View
2  auth/cas/languages.php
@@ -1,7 +1,7 @@
<?php
$caslangconstprefix = 'PHPCAS_LANG_';
-$caslangprefixlen = strlen('CAS_Language_') + 1;
+$caslangprefixlen = strlen('CAS_Languages_');
$CASLANGUAGES = array ();
$consts = get_defined_constants(true);
View
2  auth/cas/version.php
@@ -26,7 +26,7 @@
defined('MOODLE_INTERNAL') || die();
-$plugin->version = 2013052100; // The current plugin version (Date: YYYYMMDDXX)
+$plugin->version = 2013091700; // The current plugin version (Date: YYYYMMDDXX)
$plugin->requires = 2013050100; // Requires this Moodle version
$plugin->component = 'auth_cas'; // Full name of the plugin (used for diagnostics)

0 comments on commit 9953966

Please sign in to comment.
Something went wrong with that request. Please try again.