Permalink
Browse files

Files for postgresql

  • Loading branch information...
paca70
paca70 committed Apr 19, 2004
1 parent ce24161 commit a595c0b6ea1492a0914eb031334827843361743f
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function activity_modules_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function admin_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function calendar_month_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function calendar_upcoming_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function course_list_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function course_summary_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function news_items_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function online_users_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function participants_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function recent_activity_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
@@ -0,0 +1,33 @@
+<?PHP //$Id$
+//
+// This file keeps track of upgrades to Moodle's
+// blocks system.
+//
+// Sometimes, changes between versions involve
+// alterations to database structures and other
+// major things that may break installations.
+//
+// The upgrade function in this file will attempt
+// to perform all the necessary actions to upgrade
+// your older installtion to the current version.
+//
+// If there's something it cannot do itself, it
+// will tell you what you need to do.
+//
+// Versions are defined by backup_version.php
+//
+// This file is tailored to PostgreSQL
+
+function search_forums_upgrade($oldversion=0) {
+
+ global $CFG;
+
+ $result = true;
+
+ if ($oldversion < 2004041000 and $result) {
+ $result = true; //Nothing to do
+ }
+
+ //Finally, return result
+ return $result;
+}
No changes.
Oops, something went wrong.

0 comments on commit a595c0b

Please sign in to comment.