Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Merge branch 'MOODLE_21_STABLE' into install_21_STABLE

  • Loading branch information...
commit b53489190daab71c05e2135a7191a1811144c89a 2 parents 7b25272 + 3546266
authored June 26, 2012
24  admin/environment.xml
@@ -214,11 +214,7 @@
214 214
       </FEEDBACK>
215 215
     </UNICODE>
216 216
     <DATABASE level="required">
217  
-      <VENDOR name="mysql" version="5.0.25">
218  
-        <FEEDBACK>
219  
-          <ON_ERROR message="mysql416required" />
220  
-        </FEEDBACK>
221  
-      </VENDOR>
  217
+      <VENDOR name="mysql" version="5.0.25" />
222 218
       <VENDOR name="postgres" version="8.3" />
223 219
       <VENDOR name="mssql" version="9.0" />
224 220
       <VENDOR name="odbc_mssql" version="9.0" />
@@ -335,11 +331,7 @@
335 331
       </FEEDBACK>
336 332
     </UNICODE>
337 333
     <DATABASE level="required">
338  
-      <VENDOR name="mysql" version="5.0.25">
339  
-        <FEEDBACK>
340  
-          <ON_ERROR message="mysql416required" />
341  
-        </FEEDBACK>
342  
-      </VENDOR>
  334
+      <VENDOR name="mysql" version="5.0.25" />
343 335
       <VENDOR name="postgres" version="8.3" />
344 336
       <VENDOR name="mssql" version="9.0" />
345 337
       <VENDOR name="odbc_mssql" version="9.0" />
@@ -449,11 +441,7 @@
449 441
       </FEEDBACK>
450 442
     </UNICODE>
451 443
     <DATABASE level="required">
452  
-      <VENDOR name="mysql" version="5.0.25">
453  
-        <FEEDBACK>
454  
-          <ON_ERROR message="mysql416required" />
455  
-        </FEEDBACK>
456  
-      </VENDOR>
  444
+      <VENDOR name="mysql" version="5.0.25" />
457 445
       <VENDOR name="postgres" version="8.3" />
458 446
       <VENDOR name="mssql" version="9.0" />
459 447
       <VENDOR name="odbc_mssql" version="9.0" />
@@ -563,11 +551,7 @@
563 551
       </FEEDBACK>
564 552
     </UNICODE>
565 553
     <DATABASE level="required">
566  
-      <VENDOR name="mysql" version="5.0.25">
567  
-        <FEEDBACK>
568  
-          <ON_ERROR message="mysql416required" />
569  
-        </FEEDBACK>
570  
-      </VENDOR>
  554
+      <VENDOR name="mysql" version="5.1.33" />
571 555
       <VENDOR name="postgres" version="8.3" />
572 556
       <VENDOR name="mssql" version="9.0" />
573 557
       <VENDOR name="odbc_mssql" version="9.0" />
2  lib/filestorage/zip_packer.php
@@ -279,7 +279,7 @@ public function extract_to_storage($archivefile, $contextid, $component, $filear
279 279
         global $CFG;
280 280
 
281 281
         if (!is_string($archivefile)) {
282  
-            return $archivefile->extract_to_pathname($this, $contextid, $component, $filearea, $itemid, $pathbase, $userid);
  282
+            return $archivefile->extract_to_storage($this, $contextid, $component, $filearea, $itemid, $pathbase, $userid);
283 283
         }
284 284
 
285 285
         check_dir_exists($CFG->dataroot.'/temp/zip');

0 notes on commit b534891

Please sign in to comment.
Something went wrong with that request. Please try again.