Browse files

login_https is required in version 2005071601 for security reasons.

  • Loading branch information...
1 parent 95ebc7c commit b571581488a2a3daa3df6f6410cdc0fdf6cb05ad ethem committed Dec 2, 2005
Showing with 16 additions and 3 deletions.
  1. +8 −2 enrol/authorize/db/mysql.php
  2. +7 −0 enrol/authorize/db/postgres7.php
  3. +1 −1 enrol/authorize/version.php
View
10 enrol/authorize/db/mysql.php
@@ -21,9 +21,15 @@ function authorize_upgrade($oldversion=0) {
execute_sql(" ALTER TABLE `{$CFG->prefix}enrol_authorize` ADD INDEX courseid(courseid) ");
execute_sql(" ALTER TABLE `{$CFG->prefix}enrol_authorize` ADD INDEX userid(userid) ");
}
-
+
+ if ($oldversion < 2005071602) {
+ notify("<b>AUTHORIZE.NET WARNING:</b><br />
+ login_https is required in version 2005071601 for security reasons. <br />
+ Your registered users can't pay for course if you don't setup this. <br />
+ Please don't forget to set up this in section Admin/Variables/Security.");
+ }
+
return $result;
-
}
?>
View
7 enrol/authorize/db/postgres7.php
@@ -20,6 +20,13 @@ function authorize_upgrade($oldversion=0) {
modify_database('',"CREATE INDEX prefix_enrol_authorize_courseid_idx ON prefix_enrol_authorize (courseid);");
modify_database('',"CREATE INDEX prefix_enrol_authorize_userid_idx ON prefix_enrol_authorize (userid);");
}
+
+ if ($oldversion < 2005071602) {
+ notify("<b>AUTHORIZE.NET WARNING:</b><br />
+ login_https is required in version 2005071601 for security reasons. <br />
+ Your registered users can't pay for course if you don't setup this. <br />
+ Please don't forget to set up this in section Admin/Variables/Security.");
+ }
return $result;
}
View
2 enrol/authorize/version.php
@@ -1,6 +1,6 @@
<?PHP // $Id$
-$module->version = 2005071601;
+$module->version = 2005071602;
$module->requires = 2004081800;
?>

0 comments on commit b571581

Please sign in to comment.