Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge branch 'wip-MDL-27058-master' of git://github.com/samhemelryk/m…

…oodle.git (solved conflict)
  • Loading branch information...
commit fc09870e0e86ade039a746cf6c62675b39882c56 2 parents 44d872b + 356a6de
@nebgor nebgor authored
View
1  admin/settings/appearance.php
@@ -93,6 +93,7 @@
$temp->add(new admin_setting_configtext('navcourselimit',get_string('navcourselimit','admin'),get_string('confignavcourselimit', 'admin'),20,PARAM_INT));
$temp->add(new admin_setting_configcheckbox('navlinkcoursesections', get_string('navlinkcoursesections', 'admin'), get_string('navlinkcoursesections_help', 'admin'), 0));
$temp->add(new admin_setting_configcheckbox('usesitenameforsitepages', get_string('usesitenameforsitepages', 'admin'), get_string('configusesitenameforsitepages', 'admin'), 0));
+ $temp->add(new admin_setting_configcheckbox('navadduserpostslinks', get_string('navadduserpostslinks', 'admin'), get_string('navadduserpostslinks_help', 'admin'), 1));
$ADMIN->add('appearance', $temp);
View
2  lang/en/admin.php
@@ -684,6 +684,8 @@
$string['mypagelocked'] = 'Lock default page';
$string['mysql416bypassed'] = 'However, if your site is using iso-8859-1 (latin) languages ONLY, you may continue using your currently installed MySQL 4.1.12 (or higher).';
$string['mysql416required'] = 'MySQL 4.1.16 is the minimum version required for Moodle 1.6 in order to guarantee that all data can be converted to UTF-8 in the future.';
+$string['navadduserpostslinks'] = 'Add links to view user posts';
+$string['navadduserpostslinks_help'] = 'If enabled two links will be added to each user in the navigation to view discussions the user has started and posts the user has made in forums throughout the site or in specific courses.';
$string['navigationupgrade'] = 'This upgrade introduces two new navigation blocks that will replace these blocks: Administration, Courses, Activities and Participants. If you had set any special permissions on those blocks you should check to make sure everything is behaving as you want it.';
$string['navcourselimit'] = 'Course limit';
$string['navlinkcoursesections'] = 'Link course sections';
View
14 lib/navigationlib.php
@@ -1923,12 +1923,14 @@ protected function load_for_user($user=null, $forceforcontext=false) {
}
}
- // Add nodes for forum posts and discussions if the user can view either or both
- // There are no capability checks here as the content of the page is based
- // purely on the forums the current user has access too.
- $forumtab = $usernode->add(get_string('forumposts', 'forum'));
- $forumtab->add(get_string('posts', 'forum'), new moodle_url('/mod/forum/user.php', $baseargs));
- $forumtab->add(get_string('discussions', 'forum'), new moodle_url('/mod/forum/user.php', array_merge($baseargs, array('mode'=>'discussions'))));
+ if (!empty($CFG->navadduserpostslinks)) {
+ // Add nodes for forum posts and discussions if the user can view either or both
+ // There are no capability checks here as the content of the page is based
+ // purely on the forums the current user has access too.
+ $forumtab = $usernode->add(get_string('forumposts', 'forum'));
+ $forumtab->add(get_string('posts', 'forum'), new moodle_url('/mod/forum/user.php', $baseargs));
+ $forumtab->add(get_string('discussions', 'forum'), new moodle_url('/mod/forum/user.php', array_merge($baseargs, array('mode'=>'discussions'))));
+ }
// Add blog nodes
if (!empty($CFG->bloglevel)) {
View
2  version.php
@@ -31,7 +31,7 @@
-$version = 2011100700.02; // YYYYMMDD = weekly release date of this DEV branch
+$version = 2011101000.00; // YYYYMMDD = weekly release date of this DEV branch
// RR = release increments - 00 in DEV branches
// .XX = incremental changes
Please sign in to comment.
Something went wrong with that request. Please try again.