Skip to content
Permalink
master
Go to file
 
 
Cannot retrieve contributors at this time
47 lines (30 sloc) 1.26 KB

Arch Linux

If you are running Arch Linux, you can install mopidy from the "Community" repository, as well as many extensions from AUR.

Install from Community

  1. To install Mopidy with all dependencies, you can use:

    pacman -S mopidy
    

    To upgrade Mopidy to future releases, just upgrade your system using:

    pacman -Syu
    
  2. Now, you're ready to :ref:`run Mopidy <running>`.

Installing extensions

If you want to use any Mopidy extensions, like Spotify support or Last.fm scrobbling, AUR has packages for many Mopidy extensions.

To install one of the listed packages, e.g. mopidy-mpd, simply run:

yay -S mopidy-mpd

If you cannot find the extension you want in AUR, you can install it from PyPI using pip instead. Even if Mopidy itself is installed with pacman it will correctly detect and use extensions from PyPI installed globally on your system using:

sudo python3 -m pip install ...

For a comprehensive index of available Mopidy extensions, including those not installable from AUR, see the Mopidy extension registry.

You can’t perform that action at this time.