New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MP3 Sound disturbed after update on 1.0.1 #1147

Closed
sterni1971 opened this Issue Apr 25, 2015 · 8 comments

Comments

4 participants
@sterni1971

sterni1971 commented Apr 25, 2015

Hello!

I run a raspberry with hifiberry digi and
raspbian7, after update from mobidy 1.0.0-3 to 1.0.1 (via apt) the sound
of all mp3 file was disturbed. FLAC was ok. I downgraded to 1.0.0-3 everything was ok again.

The config:

[audio]
mixer = none
mixer_volume =

output = autoaudiosink

output = alsasink buffer-time=200000 latency-time=10000
visualizer =

[softwaremixer]
enabled = true

@adamcik

This comment has been minimized.

Member

adamcik commented Apr 25, 2015

Could you try increasing the value in https://github.com/mopidy/mopidy/blob/develop/mopidy/audio/actor.py#L172 to say 10, 20, 50, 100 and report back if this helps. I suspect we might have picket a too small value for that buffer.

@adamcik adamcik added this to the v1.0.2 milestone Apr 25, 2015

@sterni1971

This comment has been minimized.

sterni1971 commented Apr 25, 2015

Hi!

that solved the problem I started with 100 down to 10 and it worked all the time. In the
1.0.1 release it is btw. Line 167.

Thanks for the great software and your help.

@sterni1971 sterni1971 closed this Apr 25, 2015

@adamcik

This comment has been minimized.

Member

adamcik commented Apr 25, 2015

Value was set low to minimize the time it takes from a softvolume change to it applying to the audio being played. The larger this buffer the longer it takes, but make it to small and this happens...

So we need to retune this for a 1.0.2 release.

@adamcik adamcik reopened this Apr 25, 2015

jodal added a commit that referenced this issue Apr 26, 2015

@adamcik adamcik closed this in b80361c Apr 26, 2015

@sterni1971

This comment has been minimized.

sterni1971 commented Apr 27, 2015

I've tested as I said the values from 10 upwards and they seem for mp3 okay, but OGG vorbis
seems to be different. Here I had to increase it from 20 because of distortion. For me with 30
everything is fine.
FLAC - 5
MP3 - 10
OGG - 30

@adamcik adamcik reopened this Apr 29, 2015

@simsasaile

This comment has been minimized.

simsasaile commented Apr 29, 2015

Hi,

I had to increase the number in queue.set_property to 150. With 100 I had still really bad sound after I updated mopidy yesterday.

@adamcik

This comment has been minimized.

Member

adamcik commented Apr 30, 2015

7938ef4 is in for a 1.0.4 release, essentially setting the value to 1000ms. As it seems no matter what I pick it breaks on some system. So we are reverting to GStreamer defaults to finally get this stable for 1.0.x

@jodal jodal modified the milestones: v1.0.4, v1.0.2 Apr 30, 2015

@jodal

This comment has been minimized.

Member

jodal commented Apr 30, 2015

1.0.4 has been released. The fix is in the develop branch too.

@jodal jodal closed this Apr 30, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment