New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error unpacking pkg_resources.VersionConflict.args #911

Closed
tkem opened this Issue Dec 16, 2014 · 2 comments

Comments

3 participants
@tkem
Member

tkem commented Dec 16, 2014

Somehow I managed to install an extension with an unmet dependency/version, and got this:

2014-12-15 19:54:53,052 INFO [7923:MainThread] mopidy.__main__: Starting Mopidy 0.19.4
2014-12-15 19:54:53,433 INFO [7923:MainThread] mopidy.config: Loading config from: builtin defaults, /usr/share/mopidy/conf.d, /etc/mopidy/mopidy.conf, command line options
2014-12-15 19:54:54,860 ERROR [7923:MainThread] mopidy.__main__: need more than 1 value to unpack
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/mopidy/__main__.py", line 79, in main
    if not ext.validate_extension(extension):
  File "/usr/local/lib/python2.7/dist-packages/mopidy/ext.py", line 190, in validate_extension
    found, required = ex.args
ValueError: need more than 1 value to unpack

@jodal jodal added the C-bug label Dec 16, 2014

@jodal jodal added this to the v0.19.5 - Bug fixes milestone Dec 16, 2014

@mkaito

This comment has been minimized.

mkaito commented Dec 16, 2014

Removing mopidy-beets fixed this issue for me.

@tkem

This comment has been minimized.

Member

tkem commented Dec 16, 2014

@mkaito: Well, this issue isn't so much about the error itself, but about the error handling which doesn't work as expected.

@jodal jodal self-assigned this Dec 23, 2014

@jodal jodal closed this in 302bb7c Dec 23, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment