Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

It seems that MANIFEST and META.yml files are not needed #6

Merged
merged 1 commit into from Sep 4, 2012

Conversation

Projects
None yet
2 participants
Contributor

afiskon commented Sep 4, 2012

Do you really need them?

Collaborator

supernovus commented Sep 4, 2012

I believe they were there because this module is included on CPAN, and (at the time at least) CPAN required them. The version of JSON::Tiny on CPAN hasn't been updated since 2009, so I don't know if these files are really needed any more or not.

Contributor

afiskon commented Sep 4, 2012

CPAN is an archive of Perl 5 modules only. It was a mistake to upload JSON::Tiny there (btw, JSON::Tiny is not present on metacpan.org). Perl 6 modules are currently collected on modules.perl6.org and it's the only place where all Perl 6 modules are listed. So you need only META.info (for modules.perl6.org) and README (for GitHub).

Collaborator

supernovus commented Sep 4, 2012

I would agree to that statement. At the time when Moritz uploaded this to CPAN, it was believed CPAN would host both Perl 5 and Perl 6 modules. It never really turned out that way. Things may change in the future, but for now, I'd say you are correct. I don't see the need for these older files to be kept around.

supernovus added a commit that referenced this pull request Sep 4, 2012

Merge pull request #6 from afiskon/master
It seems that MANIFEST and META.yml files are not needed

@supernovus supernovus merged commit 8584242 into moritz:master Sep 4, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment