New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Movim is not working with PHP 7.3 #731

Closed
edhelas opened this Issue Nov 12, 2018 · 2 comments

Comments

Projects
None yet
1 participant
@edhelas
Member

edhelas commented Nov 12, 2018

The Movim daemon is actually crashing under PHP7.3 release candidate version.
This is actually caused by a bug in the ZeroMQ wrapper of PHP, see related ticket there mkoppanen/php-zmq#193.

This issue is only there to document and update the status of this related problem within the Movim project.

For the moment the 0.14 released in blocked until further announcement.

@edhelas edhelas self-assigned this Nov 12, 2018

@edhelas edhelas added the bug label Nov 12, 2018

@edhelas edhelas modified the milestones: 0.14, 0.15 Nov 12, 2018

@edhelas

This comment has been minimized.

Member

edhelas commented Nov 14, 2018

It has been decided that Movim will be released and this ticket to be tracked and, hopefully, fixed before the next release. For the Debian package a specific tag or minor release (0.14.*) will be done if the fix is coming before the 0.15.

edhelas added a commit that referenced this issue Nov 23, 2018

@edhelas edhelas modified the milestones: 0.15, 0.14.1 Nov 23, 2018

@edhelas

This comment has been minimized.

Member

edhelas commented Nov 23, 2018

The ZMQ sockets were replaced with Websockets in those previous commits.
I'm planning a couple of weeks to stabilize those changes and then release a 0.14.1 that will include the fix.

@edhelas edhelas closed this Nov 23, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment