Skip to content

IE10 HTML5 not uploading #493

Closed
ivarprudnikov opened this Issue Feb 17, 2012 · 9 comments

4 participants

@ivarprudnikov

Currently testing IE10 in Windows 8 developer preview and uploader is not working on HTML5, HTML4 is OK, FLASH is OK.

@jayarjo
Moxiecode member
jayarjo commented Feb 20, 2012

IE10 doesn't support XHR Level 2 just yet (at least it didn't, do you know if something has changed?)

@ivarprudnikov

Here we can see it should http://caniuse.com/xhr2
Related question in plupload forum http://www.plupload.com/punbb/viewtopic.php?id=1014

@jayarjo
Moxiecode member
jayarjo commented Feb 20, 2012

That's nice! I'll see were I can push it further.

@gonchuki

IE10 should be working, the version shipped in the consumer preview has support for XHR2 and the File/Blob objects.

@jayarjo
Moxiecode member
jayarjo commented Apr 4, 2012

Ok, I managed to finally get it installed. And Plupload HTML5 just worked. Even resize works out of the box. So...? Maybe you could retry with the latest Windows 8 build?

@jayarjo jayarjo closed this Apr 4, 2012
@kudos
kudos commented Apr 30, 2012

It doesn't seem to work cross-domain.

@jayarjo
Moxiecode member
jayarjo commented May 2, 2012

It doesn't depend on HTML5 runtime only, your server (to which you are planning to do a cross-domain upload), should be properly prepared as well.

@kudos
kudos commented May 2, 2012

I have CORS set up and Webkit/Gecko browsers can upload fine.

In IE10's console I get "SCRIPTS: Access is denied".

It throws that error at this line of JS https://github.com/moxiecode/plupload/blob/master/src/javascript/plupload.html5.js#L611

@jayarjo
Moxiecode member
jayarjo commented May 2, 2012

There is nothing in the code that may constrain it, so it should be something else...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.