this.connectRuntime(...).runtime is undefined in Beta #694

Closed
rvolve opened this Issue Jan 23, 2013 · 11 comments

Comments

Projects
None yet
2 participants

rvolve commented Jan 23, 2013

I'm using the latest Beta 2.0. It uploads correctly some of the time, but then I'm getting consistent upload Javascript errors part way through an upload with particular image files.

In Chrome:
Uncaught TypeError: Cannot read property 'exec' of undefined plupload.full.min.js:13

In firefox:
Timestamp: 23/01/2013 10:25:05
Error: TypeError: this.connectRuntime(...).runtime is undefined
Source File: http://test.location-collective.co.uk/js/plupload/plupload.full.min.js
Line: 13

I've tried downloading the source version but that gives me a
Timestamp: 23/01/13 11:30:09
Error: ReferenceError: plupload is not defined
Source File: http://collective/js/plupload/jquery.ui.plupload/jquery.ui.plupload.js
Line: 1012

which is probably something obvious I'm missing.

Any ideas?
Peter

Owner

jayarjo commented Jan 25, 2013

Can you share particular image files on which you encounter the error?

rvolve commented Jan 25, 2013

Hi,

I'll log in and share them in a couple of minutes.  It's also worth noting that I haven't had the problem on the Linux desktop yet, only on Windows 7.  Although I will test with these same images soon.

Thanks,
Peter

 

Peter Abrahamson
Rvolve.com
+44 (0)75 390 69877

When to call me, world-wide
http://atomjump.com/tbje430


From: Davit Barbakadze notifications@github.com
To: moxiecode/plupload plupload@noreply.github.com
Cc: rvolve webmaster@rvolve.com
Sent: Friday, January 25, 2013 2:43 PM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

Can you share particular image files on which you encounter the error?

Reply to this email directly or view it on GitHub.

rvolve commented Jan 25, 2013

Hi,

On further testing I think I've figured out what the problem is: any smaller images e.g. 400x400 which need to be scaled up have the .js errors.  Is this a common issue?  Larger images all seem to work now.

Best regards,
Peter

Peter Abrahamson
Rvolve.com
+44 (0)75 390 69877

When to call me, world-wide
http://atomjump.com/tbje430


From: Davit Barbakadze notifications@github.com
To: moxiecode/plupload plupload@noreply.github.com
Cc: rvolve webmaster@rvolve.com
Sent: Friday, January 25, 2013 2:43 PM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

Can you share particular image files on which you encounter the error?

Reply to this email directly or view it on GitHub.

Owner

jayarjo commented Jan 28, 2013

In general - no, not common and shouldn't be happening. Are you encountering the error with the latest build?

rvolve commented Jan 28, 2013

This build is about 1-2 weeks old - I'll try upgrading today.

Peter Abrahamson
+44 (0)75 390 69877

When to call me, world-wide
http://atomjump.com/tbje430


From: Davit Barbakadze notifications@github.com
To: moxiecode/plupload plupload@noreply.github.com
Cc: rvolve webmaster@rvolve.com
Sent: Monday, January 28, 2013 9:58 AM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

In general - no, not common and shouldn't be happening. Are you encountering the error with the latest build?

Reply to this email directly or view it on GitHub.

rvolve commented Jan 28, 2013

Hi, it seems to be fixed in the latest build!  Thanks for the suggestion.

+44 (0)75 390 69877

When to call me, world-wide
http://atomjump.com/tbje430


From: Davit Barbakadze notifications@github.com
To: moxiecode/plupload plupload@noreply.github.com
Cc: rvolve webmaster@rvolve.com
Sent: Monday, January 28, 2013 9:58 AM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

In general - no, not common and shouldn't be happening. Are you encountering the error with the latest build?

Reply to this email directly or view it on GitHub.

Owner

jayarjo commented Jan 28, 2013

Thanks for testing with us.

jayarjo closed this Jan 28, 2013

rvolve commented Jan 28, 2013

Hi,

Sorry to backtrack here.  The problem appeared to be fixed on all of my test cases on linux/Firefox 17, however Google Chrome/Windows 7 still has the issue.

I've attached an image which breaks, and an image which goes through successfully:

2.jpg seems to fail

4.jpg seems to work

Below is my config. Thanks for your help.  BTW I don't think I have the jquery cookie plugin included - should I switch off remember_view ?

Peter Abrahamson

$(function() {

$("#uploader").plupload({

// General settings

runtimes : 'html5,flash,silverlight,html4',

url : 'locationphotosupload.php?id=10883&plupload=true',

max_file_size : '1000mb',

max_file_count: 1000, // user can add no more then 1000 files at a time

chunk_size : '1mb',

unique_names : true,

multiple_queues : true,

// Resize images on clientside if we can

resize : {

width : 716,

height : 466,

quality : 100,

crop: false // crop to exact dimensions

},

// Specify what files to browse for

filters : [

{title : "Image files", extensions : "jpg,gif,png"},

{title : "Zip files", extensions : "zip,avi"}

],

// Flash settings

flash_swf_url : '../js/plupload/Moxie.swf',

// Silverlight settings

silverlight_xap_url : '../js/plupload/Moxie.xap',

// Rename files by clicking on their titles

rename: true,

// Sort files

sortable: true,

// Enable ability to drop files onto the widget (currently only HTML5 supports that)

dragdrop: true,

// Views to activate

views: {

list: true,

thumbs: true // Show thumbs

},

default_view: 'thumbs',

remember_view: true // requires jquery cookie plugin

});


From: Davit Barbakadze notifications@github.com
To: moxiecode/plupload plupload@noreply.github.com
Cc: rvolve webmaster@rvolve.com
Sent: Monday, January 28, 2013 12:50 PM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

Thanks for testing with us.

Reply to this email directly or view it on GitHub.

rvolve commented Jan 28, 2013

Ah, I've just noticed a pattern - the small portrait images aren't working while the small landscape images now are.

Peter Abrahamson

When to call me, world-wide
http://atomjump.com/tbje430


From: Peter Abrahamson webmaster@rvolve.com
To: moxiecode/plupload reply@reply.github.com
Sent: Monday, January 28, 2013 1:06 PM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

Hi,

Sorry to backtrack here.  The problem appeared to be fixed on all of my test cases on linux/Firefox 17, however Google Chrome/Windows 7 still has the issue.

I've attached an image which breaks, and an image which goes through successfully:

2.jpg seems to fail

4.jpg seems to work

Below is my config. Thanks for your help.  BTW I don't think I have the jquery cookie plugin included - should I switch off remember_view ?

Peter Abrahamson

$(function() {

$("#uploader").plupload({

// General settings

runtimes : 'html5,flash,silverlight,html4',

url : 'locationphotosupload.php?id=10883&plupload=true',

max_file_size : '1000mb',

max_file_count: 1000, // user can add no more then 1000 files at a time

chunk_size : '1mb',

unique_names : true,

multiple_queues : true,

// Resize images on clientside if we can

resize : {

width : 716,

height : 466,

quality : 100,

crop: false // crop to exact dimensions

},

// Specify what files to browse for

filters : [

{title : "Image files", extensions : "jpg,gif,png"},

{title : "Zip files", extensions : "zip,avi"}

],

// Flash settings

flash_swf_url : '../js/plupload/Moxie.swf',

// Silverlight settings

silverlight_xap_url : '../js/plupload/Moxie.xap',

// Rename files by clicking on their titles

rename: true,

// Sort files

sortable: true,

// Enable ability to drop files onto the widget (currently only HTML5 supports that)

dragdrop: true,

// Views to activate

views: {

list: true,

thumbs: true // Show thumbs

},

default_view: 'thumbs',

remember_view: true // requires jquery cookie plugin

});


From: Davit Barbakadze notifications@github.com
To: moxiecode/plupload plupload@noreply.github.com
Cc: rvolve webmaster@rvolve.com
Sent: Monday, January 28, 2013 12:50 PM
Subject: Re: [plupload] this.connectRuntime(...).runtime is undefined in Beta (#694)

Thanks for testing with us.

Reply to this email directly or view it on GitHub.

jayarjo reopened this Jan 28, 2013

Owner

jayarjo commented Jan 28, 2013

Sorry, where did you attach failed images?

rvolve commented Jan 28, 2013

2
4

Sorry, here are the images.

jayarjo closed this Feb 17, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment