New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No spacing between 'featured' badge and theme preview in Theme details page #4626

Closed
AlexandraMoga opened this Issue Mar 22, 2018 · 4 comments

Comments

Projects
None yet
4 participants
@AlexandraMoga

AlexandraMoga commented Mar 22, 2018

Follow up for #4520

STR:

  1. Log in to AMO and select a featured theme to view it's details page (i.e. https://addons.allizom.org/en-GB/firefox/addon/dew-on-spider-web/?src=featured)
  2. Observe the position of the featured label

Actual result:
There is no spacing between the featured badge and theme preview

Expected result:
Some space should be present between the featured badge and the theme preview

Notes:

  • reproduced on AMO-stage, FF59 Win10x64

image

@svitlana-galianova

This comment has been minimized.

Contributor

svitlana-galianova commented Mar 26, 2018

Hello, I would like to help out with this one.

@svitlana-galianova

This comment has been minimized.

Contributor

svitlana-galianova commented Mar 28, 2018

I am trying to access this link (http://localhost:3000/en-GB/firefox/addon/dew-on-spider-web/?src=featured) while running amo locally (I tried both amo:stage and amo:dev), but I keep getting this error:
Maybe I am doing something wrong or missing some step?

[1]  Error: Error calling: /api/v3/accounts/profile/ (status: 500)
[1]     at createApiError (/.../addons-frontend/src/core/api/index.js:59:20)
[1]     at /.../addons-frontend/src/core/api/index.js:189:24
[1]     at <anonymous>
[1]     at process._tickDomainCallback (internal/process/next_tick.js:228:7)
[1] [2018-03-28T15:37:02.561Z] ERROR: server/86882 on mac...: Caught error during rendering: Error: Error calling: /api/v3/accounts/profile/ (status: 500) (app=amo)
[1] [2018-03-28T15:37:02.561Z] ERROR: server/86882 on mac...: Showing 500 page for error: Error: Error calling: /api/v3/accounts/profile/ (status:500) (app=amo)
[1] [2018-03-28T15:37:02.562Z] ERROR: server/86882 on mac...: Error calling: /api/v3/accounts/profile/ (status: 500) (app=amo)
[1]     Error: Error calling: /api/v3/accounts/profile/ (status: 500)
[1]         at createApiError (/.../addons-frontend/src/core/api/index.js:59:20)
[1]         at /.../addons-frontend/src/core/api/index.js:189:24
[1]         at <anonymous>
[1]         at process._tickDomainCallback (internal/process/next_tick.js:228:7)
[1] Warning: Failed prop type: The prop `component` is marked as required in `ServerHtml`, but its value is `undefined`.
[1]     in ServerHtml
[2] [2018-03-28T15:37:02.567Z]  INFO: proxy/86875 on mac...: 500 ~> http://127.0.0.1:3333/en-GB/firefox/addon/dew-on-spider-web/?src=featured (app=amo)
@svitlana-galianova

This comment has been minimized.

Contributor

svitlana-galianova commented Apr 2, 2018

I have started amo:dev and it solved that issue for me

@AlexandraMoga

This comment has been minimized.

AlexandraMoga commented Apr 3, 2018

Verified as fixed on AMO-dev with FF59, Win10x64

image

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment