Skip to content

Bug 974005 - Add back Gigabit Blog link #1716

Merged
merged 1 commit into from Feb 24, 2014

2 participants

@mmmavis
Mozilla member
mmmavis commented Feb 19, 2014
@alexgibson alexgibson commented on an outdated diff Feb 20, 2014
bedrock/gigabit/templates/gigabit/apply.html
@@ -23,6 +23,7 @@
<ul id="nav-main-menu">
<li>{{_('<a href="%s">Home</a>')|format(url('gigabit.gigabit')) }}</li>
<li><b>{{_('Apply')}}</b></li>
+ <li><a href="http://blog.mozilla.org/gigabit/">{{_('Blog')}}</a>
@alexgibson
Mozilla member
alexgibson added a note Feb 20, 2014

Looks like you're missing the closing </li> here?

Also the link can use https:// instead of http://

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@alexgibson alexgibson and 1 other commented on an outdated diff Feb 20, 2014
bedrock/gigabit/templates/gigabit/gigabit.html
@@ -23,6 +23,7 @@
<ul id="nav-main-menu">
<li><b>{{_('Home')}}</b></li>
<li>{{_('<a href="%s">Apply</a>')|format(url('gigabit.apply')) }}</li>
+ <li><a href="http://blog.mozilla.org/gigabit/">{{_('Blog')}}</a>
@alexgibson
Mozilla member
alexgibson added a note Feb 20, 2014

Same as above

@mmmavis
Mozilla member
mmmavis added a note Feb 21, 2014

ah, I'll fix it =)

Is there a general guideline about when to use protocol relative urls and when to specify them?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@alexgibson
Mozilla member

I didn't mean use a protocol relative URL, just change it to https. If you click the link you will see it redirects to https anyway, so you might as well just set it directly.

You generally don't need to use protocol relative URL's on page links, only for loading resources (e.g. embedding a video or loading a remote JS). There's a good article on protocol relative URL's here: http://www.paulirish.com/2010/the-protocol-relative-url/

@mmmavis
Mozilla member
mmmavis commented Feb 21, 2014

thanks Alex!

Now let me practice with rebasing & squashing =)

@mmmavis
Mozilla member
mmmavis commented Feb 21, 2014

ummm looks like I did something wrong again?

@alexgibson
Mozilla member

You may just need to try rebasing again.

There are some steps to follow in the Git workflow section in our docs: http://bedrock.readthedocs.org/en/latest/contribute.html#git-workflow

Once rebased you can squash your commits: http://bedrock.readthedocs.org/en/latest/contribute.html#squashing-your-commits

@alexgibson
Mozilla member

r+

@alexgibson alexgibson merged commit d74bee6 into mozilla:master Feb 24, 2014

1 check passed

Details default Jenkins build 'bedrock_github' #3278 has succeeded
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.