Permalink
Browse files

Bug 805440 - Mozrunner installed from pypi when running setup_develop…

…ment.py;r=mcote
  • Loading branch information...
1 parent 68d8de6 commit 1f679a8ae3ff49d1e3c96cbf3c01ad4742568e1b Jeff Hammel committed Oct 27, 2012
Showing with 5 additions and 5 deletions.
  1. +5 −5 setup_development.py
View
@@ -216,8 +216,12 @@ def main(args=sys.argv[1:]):
print package
parser.exit()
+ # set up the packages for development
+ for package in unrolled:
+ call([sys.executable, 'setup.py', 'develop', '--no-deps'],
+ cwd=os.path.join(here, reverse_mapping[package]))
+
# install non-mozbase dependencies
- # (currently none on modern python)
# these need to be installed separately and the --no-deps flag
# subsequently used due to a bug in setuptools; see
# https://bugzilla.mozilla.org/show_bug.cgi?id=759836
@@ -227,10 +231,6 @@ def main(args=sys.argv[1:]):
# easy_install should be available since we rely on setuptools
call(['easy_install', version])
- # set up the packages for development
- for package in unrolled:
- call([sys.executable, 'setup.py', 'develop', '--no-deps'],
- cwd=os.path.join(here, reverse_mapping[package]))
if __name__ == '__main__':
main()

0 comments on commit 1f679a8

Please sign in to comment.