Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Add emulator files to mozdevice #28

Closed
wants to merge 5 commits into from

1 participant

@jonallengriffin

This adds the new emulator files to the mozdevice package, and bumps the version so we can post to pypi. Will adding a mozprocess dependency to mozdevice create problems for any consumers of mozdevice?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jul 19, 2012
  1. @jonallengriffin
Commits on Jul 24, 2012
  1. @jonallengriffin
  2. @jonallengriffin

    Bump version #

    jonallengriffin authored
Commits on Aug 1, 2012
  1. @jonallengriffin
Commits on Aug 6, 2012
  1. @jonallengriffin
This page is out of date. Refresh to see the latest.
Showing with 7 additions and 2 deletions.
  1. +3 −0  mozdevice/mozdevice/__init__.py
  2. +4 −2 mozdevice/setup.py
View
3  mozdevice/mozdevice/__init__.py
@@ -6,3 +6,6 @@
from devicemanagerADB import DeviceManagerADB
from devicemanagerSUT import DeviceManagerSUT
from droid import DroidADB, DroidSUT
+from emulator import Emulator
+from b2gemulator import B2GEmulator
+
View
6 mozdevice/setup.py
@@ -5,7 +5,7 @@
import os
from setuptools import setup, find_packages
-PACKAGE_VERSION = '0.3'
+PACKAGE_VERSION = '0.4'
# take description from README
here = os.path.dirname(os.path.abspath(__file__))
@@ -14,6 +14,8 @@
except (OSError, IOError):
description = ''
+deps = ['mozprocess==0.4']
+
setup(name='mozdevice',
version=PACKAGE_VERSION,
description="Mozilla-authored device management",
@@ -27,7 +29,7 @@
packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data=True,
zip_safe=False,
- install_requires=[],
+ install_requires=deps,
entry_points="""
# -*- Entry points: -*-
[console_scripts]
Something went wrong with that request. Please try again.