Skip to content
Commits on Apr 19, 2016
  1. @KaiRo-at

    Use branch of *target* instead of source build

    KaiRo-at committed Apr 19, 2016
    I tested with manual triggering of an update job that for RC builds (the only case where the repository/branch of the target and source builds differs), the ondemand_update jobs run correctly with the "mozilla-release" (target) instead of the "mozilla-beta" (source) branch name handed over.
    
    A failing job triggered before this change is http://mm-ci-production.qa.scl3.mozilla.com:8080/job/ondemand_update/26069/console
    A manual try with different branch is http://mm-ci-production.qa.scl3.mozilla.com:8080/job/ondemand_update/26070/console (and it's also green on treeherder)
    
    The config fed to trigger-ondemand that causes the failures is https://wiki.mozilla.org/QA/Desktop_Firefox/Releases/Configs/Fx46RC1
    
    If I see things correctly, line 198 ends up assigning the *target* build's branch to testrun['branch'] so we can use that instead of build_details['branch'] which is derived from /entry/ which is the source build's version.
Commits on Mar 30, 2016
  1. @whimboo
Commits on Mar 29, 2016
  1. @whimboo
Commits on Mar 24, 2016
  1. @whimboo
Commits on Mar 23, 2016
  1. @whimboo

    Revert "Disable version check for newer pip releases (#775)"

    whimboo committed Mar 23, 2016
    This reverts commit f57b039.
  2. @whimboo
Commits on Mar 21, 2016
  1. @whimboo
Commits on Mar 14, 2016
  1. @whimboo
Commits on Mar 11, 2016
  1. @whimboo
  2. @whimboo
Commits on Feb 26, 2016
  1. @whimboo
Commits on Feb 22, 2016
  1. @whimboo
Commits on Feb 14, 2016
  1. @edmorley
Commits on Feb 9, 2016
  1. @whimboo
Commits on Jan 28, 2016
  1. @whimboo
Commits on Jan 22, 2016
  1. @whimboo
Commits on Jan 18, 2016
  1. @whimboo
Commits on Jan 15, 2016
  1. @whimboo
Commits on Jan 6, 2016
  1. @edmorley @whimboo

    Pin the sub-dependencies of packages in the workspace requirements.txt (

    edmorley committed with whimboo Jan 6, 2016
    #725)
    
    To avoid unexpected breakage when those packages are updated with
    backwards-incompatible changes.
    
    Fixes #725.
  2. @whimboo
Commits on Jan 5, 2016
  1. @whimboo
Commits on Jan 4, 2016
  1. @whimboo
Commits on Dec 11, 2015
  1. @whimboo
Commits on Dec 4, 2015
  1. @whimboo
  2. @whimboo
Commits on Dec 2, 2015
  1. @whimboo
Commits on Dec 1, 2015
  1. @whimboo
  2. @whimboo
  3. @whimboo
Commits on Nov 30, 2015
  1. @whimboo
Commits on Nov 27, 2015
  1. @whimboo
  2. @whimboo
Commits on Nov 25, 2015
  1. @whimboo
Commits on Nov 16, 2015
  1. @whimboo
Commits on Nov 9, 2015
  1. @whimboo
Something went wrong with that request. Please try again.