Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Bug 877131 - Release Mozmill 2.0rc4. r=ctalbert

  • Loading branch information...
commit 31c98c9a4ea606472b95897e8a3332bb50abb7ee 1 parent cf49285
@whimboo whimboo authored
View
5 jsbridge/History.md
@@ -1,3 +1,8 @@
+3.0rc4 / 2013-06-14
+===================
+
+ * Bug 865690 - Wallpaper fix for 'I/O method is invalid' assertion
+
3.0rc3 / 2013-05-08
===================
View
2  jsbridge/jsbridge/extension/install.rdf
@@ -5,7 +5,7 @@
<Description about="urn:mozilla:install-manifest">
<em:id>jsbridge@mozilla.com</em:id>
<em:name>jsbridge</em:name>
- <em:version>3.0rc3</em:version>
+ <em:version>3.0rc4</em:version>
<em:description>Python to JavaScript bridge</em:description>
<em:unpack>true</em:unpack>
View
2  jsbridge/setup.py
@@ -7,7 +7,7 @@
from setuptools import setup, find_packages
PACKAGE_NAME = "jsbridge"
-PACKAGE_VERSION = "3.0rc3"
+PACKAGE_VERSION = "3.0rc4"
# package dependencies
deps = []
View
13 mozmill/History.md
@@ -1,3 +1,16 @@
+2.0rc3 / 2013-06-14
+===================
+
+ * Bug 879371 - Add support for tabs and window handling for Firefox Metro
+ * Bug 876399 - Mozmill module loader should prevent leaking of symbols through the global object by using a sandbox
+ * Bug 874895 - Upgrade EventUtils to most recent version
+ * Bug 879371 - Allow Mozmill to close Firefox Metro
+ * Bug 860662 - controller.select() fails to select the option by value
+ * Bug 872237 - ChromeWindows cannot be initialized correctly because onWindowLoaded is called sometimes even with window not finished loading yet
+ * Bug 795579 - waitFor method doesn't send a pass frame which can cause an application disconnect when handled in a loop
+ * Bug 860659 - elementslib.Lookup() fails if element in reduceLookup() does not exist yet
+ * Bug 870799 - Update windowMap API to always use outer window id as parameter
+
2.0rc3 / 2013-05-08
===================
View
4 mozmill/mozmill/extension/install.rdf
@@ -5,7 +5,7 @@
<Description about="urn:mozilla:install-manifest">
<em:id>mozmill@mozilla.com</em:id>
<em:name>Mozmill</em:name>
- <em:version>2.0rc3</em:version>
+ <em:version>2.0rc4</em:version>
<em:description>UI Automation tool for Mozilla applications</em:description>
<em:unpack>true</em:unpack>
@@ -17,7 +17,7 @@
<Description>
<em:id>toolkit@mozilla.org</em:id>
<em:minVersion>10.0</em:minVersion>
- <em:maxVersion>23.*</em:maxVersion>
+ <em:maxVersion>24.*</em:maxVersion>
</Description>
</em:targetApplication>
</Description>
View
4 mozmill/setup.py
@@ -6,9 +6,9 @@
from setuptools import setup, find_packages
PACKAGE_NAME = "mozmill"
-PACKAGE_VERSION = "2.0rc3"
+PACKAGE_VERSION = "2.0rc4"
-deps = ['jsbridge == 3.0rc3',
+deps = ['jsbridge == 3.0rc4',
'ManifestDestiny == 0.5.6',
'mozinfo == 0.4',
'mozrunner == 5.18',
Please sign in to comment.
Something went wrong with that request. Please try again.