Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

checkCompatibility version updates. Helps to fix Issue #95. #103

Closed
wants to merge 1 commit into from

2 participants

@xabolcs
Owner

This is a pull to help fix Issue #95 in the case if Issue #52 doesn't get merged till the due date of milestone 3.4.

If #52 lands into release 3.4, then this pull request should be closed without merging.

@whimboo
Owner

I don't have the time this week to check the pull request on issue #52. So I would propose we go ahead with this pull and move #52 to version 3.5. I will get this merged.

@whimboo
Owner

For the future please try to stick with a commit message like: "description (#pull)". That makes it easier for me to merge.

@whimboo whimboo closed this
@xabolcs xabolcs referenced this pull request from a commit in xabolcs/nightlytt
@xabolcs xabolcs Update checkCompatibility preferences for compatibility (#103) df7e36c
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Oct 25, 2012
  1. @xabolcs
This page is out of date. Refresh to see the latest.
Showing with 50 additions and 1 deletion.
  1. +50 −1 extension/components/nttAddonCompatibilityService.js
View
51 extension/components/nttAddonCompatibilityService.js
@@ -74,6 +74,20 @@ nttAddonCompatibilityService.prototype = {
"extensions.checkCompatibility.14.0a",
"extensions.checkCompatibility.15.0",
"extensions.checkCompatibility.15.0a",
+ "extensions.checkCompatibility.16.0",
+ "extensions.checkCompatibility.16.0a",
+ "extensions.checkCompatibility.17.0",
+ "extensions.checkCompatibility.17.0a",
+ "extensions.checkCompatibility.18.0",
+ "extensions.checkCompatibility.18.0a",
+ "extensions.checkCompatibility.19.0",
+ "extensions.checkCompatibility.19.0a",
+ "extensions.checkCompatibility.20.0",
+ "extensions.checkCompatibility.20.0a",
+ "extensions.checkCompatibility.21.0",
+ "extensions.checkCompatibility.21.0a",
+ "extensions.checkCompatibility.22.0",
+ "extensions.checkCompatibility.22.0a",
"extensions.checkCompatibility.nightly"];
var appInfo = Components.classes["@mozilla.org/xre/app-info;1"]
@@ -106,6 +120,20 @@ nttAddonCompatibilityService.prototype = {
"extensions.checkCompatibility.14.0a",
"extensions.checkCompatibility.15.0",
"extensions.checkCompatibility.15.0a",
+ "extensions.checkCompatibility.16.0",
+ "extensions.checkCompatibility.16.0a",
+ "extensions.checkCompatibility.17.0",
+ "extensions.checkCompatibility.17.0a",
+ "extensions.checkCompatibility.18.0",
+ "extensions.checkCompatibility.18.0a",
+ "extensions.checkCompatibility.19.0",
+ "extensions.checkCompatibility.19.0a",
+ "extensions.checkCompatibility.20.0",
+ "extensions.checkCompatibility.20.0a",
+ "extensions.checkCompatibility.21.0",
+ "extensions.checkCompatibility.21.0a",
+ "extensions.checkCompatibility.22.0",
+ "extensions.checkCompatibility.22.0a",
"extensions.checkCompatibility.nightly"];
}
else if (appInfo.name == "SeaMonkey") {
@@ -134,15 +162,36 @@ nttAddonCompatibilityService.prototype = {
"extensions.checkCompatibility.2.10a",
"extensions.checkCompatibility.2.11",
"extensions.checkCompatibility.2.11a",
+ "extensions.checkCompatibility.2.12",
+ "extensions.checkCompatibility.2.12a",
+ "extensions.checkCompatibility.2.13",
+ "extensions.checkCompatibility.2.13a",
+ "extensions.checkCompatibility.2.14",
+ "extensions.checkCompatibility.2.14a",
+ "extensions.checkCompatibility.2.15",
+ "extensions.checkCompatibility.2.15a",
+ "extensions.checkCompatibility.2.16",
+ "extensions.checkCompatibility.2.16a",
+ "extensions.checkCompatibility.2.17",
+ "extensions.checkCompatibility.2.17a",
+ "extensions.checkCompatibility.2.18",
+ "extensions.checkCompatibility.2.18a",
"extensions.checkCompatibility.nightly"];
}
else if (appInfo.name == "Songbird") {
prefs = ["extensions.checkCompatibility",
+ "extensions.checkCompatibility.1.6",
+ "extensions.checkCompatibility.1.7",
"extensions.checkCompatibility.1.8",
"extensions.checkCompatibility.1.9",
"extensions.checkCompatibility.1.10",
"extensions.checkCompatibility.1.11",
- "extensions.checkCompatibility.1.12"];
+ "extensions.checkCompatibility.1.12",
+ "extensions.checkCompatibility.2.0",
+ "extensions.checkCompatibility.2.1",
+ "extensions.checkCompatibility.2.2",
+ "extensions.checkCompatibility.2.3",
+ "extensions.checkCompatibility.2.4"];
}
var enable = !this.prefService.getBoolPref("nightly.disableCheckCompatibility");
Something went wrong with that request. Please try again.