New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

It doesn't work with 2.1 and 2.2 simulators #1

Closed
sole opened this Issue Jan 30, 2015 · 1 comment

Comments

Projects
None yet
1 participant
@sole
Member

sole commented Jan 30, 2015

There is a what I think is the same bug filed here: FirefoxOS simulator 2.2 StyleSheets getStyleSheets throw error from remote debugger but the paste bin has expired and I can't see if it's the same error.

We need to write a smaller test case that shows the error so devtools people can debug it and see what's going on-the test pseudocode would be:

  • launch simulator
  • connect to obtain client
  • launch app
  • get app tab/actor using the client
  • see how tab.StyleSheets.getStyleSheets never calls the callback in 2.1 or 2.2, but does in 2.0

Essentially the conflicting code is the code of this module

@sole

This comment has been minimized.

Show comment
Hide comment
@sole
Member

sole commented Mar 20, 2015

@sole sole closed this in 0be7783 Mar 26, 2015

tofumatt added a commit that referenced this issue Mar 26, 2015

Merge pull request #4 from sole/fix-bug-1
Attach to tab before accessing stylesheets object - fixes #1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment