Node 0.8.x support #1914

Merged
merged 2 commits into from Jul 7, 2012

3 participants

@lloyd

teensy patch, doesn't break 0.6, lets devs work with 0.8 if they want to and lets us start exploring it. (really all this does is eliminate deprecation warnings)

@jedp jedp was assigned Jul 5, 2012
@zaach

+1

@lloyd

@jedp notes that I overlooked the fact that 0.6 fs has no .existsSync - doh! I swore I tested that! he's taking the PR and will patch

so r-

@jedp

Jeeeeesus! Sorry about the rebase mess. It seemed I needed some of those earlier updates. But oi, sorry.

Here's my bit - just a wrapper for existsSync! Commit 09f65ff

@lloyd

r+ on jedp's update to this patch. tested on 0.6 and 0.8 - no deprecation output on console from unit tests.

@lloyd lloyd merged commit 5ccc669 into dev Jul 7, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment