Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Fetching latest commit…

Cannot retrieve the latest commit at this time

..
Failed to load latest commit information.
1.7.7
1.7.8
11.0
13.0
14.0
15.0
16.0
17.7
18.0
19.0
2.0
2.1.1
2.1
2.2.3
2.2.4
2.2.6
2.2
2.3.1
2.3.2
2.3.3
2.3.4.1
2.3.4
2.3.5
2.3
2.4.1
2.4.2
2.4.3
2.4.4
2.4
2.5.0.1
2.5.1
2.5.2
2.5
3.0
4.0
5.0
8.0
9.0
README
auto-upgrade.py

README

Each of the directories in scripts/upgrade corresponds to a single Soccorro version.  Each contains one or several SQL and python scripts for upgrading the PostgreSQL database to support that Socorro version from the immediate prior version.

If the set of scripts is complete and ready for deployment, there will be an update.sh shell script which runs all the upgrade scripts in the correct order.  This shell script must be run as the "postgres" user from that directory, on the PostgreSQL database server, with passwordless authentication.  If update.sh is not present, the version is not ready for deployment.

In some cases the scripts to be run for dev/staging are slightly differenct from the scripts to be run for deploying in production.  In that case, there will be an update-dev.sh script which should be run instead on dev and staging.
Something went wrong with that request. Please try again.