Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Trigger production deployments on pushes to prod branch #514

Merged
merged 1 commit into from Jan 9, 2020

Conversation

@jgmize
Copy link
Contributor

jgmize commented Jan 8, 2020

Description

Per discussion in #websites channel in slack let's trigger production deployments on push to the prod branch.

@jgmize jgmize requested review from stephaniehobson and pmac Jan 8, 2020
@metadave

This comment has been minimized.

Copy link
Member

metadave commented Jan 9, 2020

it would be nice to have a few words in the readme about how to deploy to prod:
ex. https://github.com/mozilla/irlpodcast#pushing-to-production

@glogiotatidis

This comment has been minimized.

Copy link
Member

glogiotatidis commented Jan 9, 2020

it would be nice to have a few words in the readme about how to deploy to prod:
ex. https://github.com/mozilla/irlpodcast#pushing-to-production

The mana page is up to date and has instructions, albeit maybe not detailed. I will also add a link to the pipeline in the readme.

@glogiotatidis

This comment has been minimized.

Copy link
Member

glogiotatidis commented Jan 9, 2020

Merging this to test the trigger. Will also add instructions

@glogiotatidis glogiotatidis merged commit 13a5b32 into master Jan 9, 2020
1 check passed
1 check passed
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@glogiotatidis

This comment has been minimized.

Copy link
Member

glogiotatidis commented Jan 9, 2020

Also added instructions b6c2fa4

@glogiotatidis glogiotatidis deleted the deploy-prod-branch branch Jan 9, 2020
@glogiotatidis

This comment has been minimized.

Copy link
Member

glogiotatidis commented Jan 9, 2020

Had to set prod branch to be protected in Gitlab for the Creds to be applied in the environment. And also commit 1284e69 to make robots work

Everything seems to work now. Thanks everyone!

btw @jgmize do you mind not pushing branches to the main repos and instead do it to your fork? It pollutes the namespace in both github and gitlab

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.