Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Aug 10, 2010

  1. ashbb

    Refactored Rakefile more readable. Divided Rakefile into the followin…

    …g 4 files.
    
      - Rakefile
      - rakefile_mingw.rb
      - rakefile_linux.rb
      - rakefile_darwin.rb
    authored August 05, 2010 martindemello committed August 10, 2010

Jul 01, 2010

  1. ashbb

    Oops, mistook to merge. Previous Rakefile didn't work for Linux. Now …

    …corrected.
    authored July 01, 2010

Jun 29, 2010

  1. ashbb

    Merge commit 'shoes/master'

    Corrected the following conflicts by hand:
    	Rakefile
    	req/rubygems/rubygems.rb
    	req/rubygems/rubygems/builder.rb
    	req/rubygems/rubygems/command.rb
    	req/rubygems/rubygems/command_manager.rb
    	req/rubygems/rubygems/commands/check_command.rb
    	req/rubygems/rubygems/commands/cleanup_command.rb
    	req/rubygems/rubygems/commands/contents_command.rb
    	req/rubygems/rubygems/commands/generate_index_command.rb
    	req/rubygems/rubygems/commands/install_command.rb
    	req/rubygems/rubygems/commands/query_command.rb
    	req/rubygems/rubygems/commands/rdoc_command.rb
    	req/rubygems/rubygems/commands/search_command.rb
    	req/rubygems/rubygems/commands/server_command.rb
    	req/rubygems/rubygems/commands/sources_command.rb
    	req/rubygems/rubygems/commands/specification_command.rb
    	req/rubygems/rubygems/commands/uninstall_command.rb
    	req/rubygems/rubygems/commands/unpack_command.rb
    	req/rubygems/rubygems/commands/update_command.rb
    	req/rubygems/rubygems/commands/which_command.rb
    	req/rubygems/rubygems/config_file.rb
    	req/rubygems/rubygems/custom_require.rb
    	req/rubygems/rubygems/defaults.rb
    	req/rubygems/rubygems/dependency.rb
    	req/rubygems/rubygems/dependency_installer.rb
    	req/rubygems/rubygems/dependency_list.rb
    	req/rubygems/rubygems/digest/digest_adapter.rb
    	req/rubygems/rubygems/digest/sha1.rb
    	req/rubygems/rubygems/digest/sha2.rb
    	req/rubygems/rubygems/doc_manager.rb
    	req/rubygems/rubygems/exceptions.rb
    	req/rubygems/rubygems/ext/builder.rb
    	req/rubygems/rubygems/ext/configure_builder.rb
    	req/rubygems/rubygems/ext/ext_conf_builder.rb
    	req/rubygems/rubygems/ext/rake_builder.rb
    	req/rubygems/rubygems/format.rb
    	req/rubygems/rubygems/gem_openssl.rb
    	req/rubygems/rubygems/gem_path_searcher.rb
    	req/rubygems/rubygems/gem_runner.rb
    	req/rubygems/rubygems/indexer.rb
    	req/rubygems/rubygems/install_update_options.rb
    	req/rubygems/rubygems/installer.rb
    	req/rubygems/rubygems/local_remote_options.rb
    	req/rubygems/rubygems/old_format.rb
    	req/rubygems/rubygems/package/f_sync_dir.rb
    	req/rubygems/rubygems/package/tar_header.rb
    	req/rubygems/rubygems/package/tar_input.rb
    	req/rubygems/rubygems/package/tar_output.rb
    	req/rubygems/rubygems/package/tar_reader.rb
    	req/rubygems/rubygems/package/tar_reader/entry.rb
    	req/rubygems/rubygems/package/tar_writer.rb
    	req/rubygems/rubygems/platform.rb
    	req/rubygems/rubygems/remote_fetcher.rb
    	req/rubygems/rubygems/require_paths_builder.rb
    	req/rubygems/rubygems/requirement.rb
    	req/rubygems/rubygems/server.rb
    	req/rubygems/rubygems/source_index.rb
    	req/rubygems/rubygems/source_info_cache_entry.rb
    	req/rubygems/rubygems/spec_fetcher.rb
    	req/rubygems/rubygems/specification.rb
    	req/rubygems/rubygems/timer.rb
    	req/rubygems/rubygems/uninstaller.rb
    	req/rubygems/rubygems/user_interaction.rb
    	req/rubygems/rubygems/validator.rb
    	req/rubygems/rubygems/version.rb
    	req/rubygems/rubygems/version_option.rb
    authored June 30, 2010
  2. ashbb

    At last I understood that there was no need to use `req/rubygems`. Ru…

    …by 1.9.1 is including rubygems! So, decided to delete req/rubygems. If you'd like to update rubygems in Shoes, you can use Shoes.setup.
    authored June 30, 2010

Jun 24, 2010

  1. ashbb

    Included chipmunk v4.1.0. Let's create chipmunk physics demo on Shoes!

    authored June 24, 2010

May 29, 2010

  1. ashbb

    Updated the following dependencies for Windows.

    - pango : from 1.22 to 1.28
    - glib  : from 2.18 to 2.24
    authored May 29, 2010

May 09, 2010

  1. ashbb

    Reverted a little to build Policeman for Linux. Look at this small no…

    authored May 09, 2010

May 08, 2010

  1. ashbb

    Revised Rakefile and world.c to build Policeman for Linux.

    authored May 08, 2010

Apr 20, 2010

  1. ashbb

    Took in i5m's nice suggestion to build Shoes anywhere.

    authored April 20, 2010

Apr 11, 2010

  1. ashbb

    Edited a little bit for building Shoes with Ruby 1.8.7. Now you can b…

    …uild Shoes both with Ruby 1.9.1 and 1.8.7. You can confirm Shoes version included Ruby version by `shoes -v`.
    authored April 11, 2010

Apr 02, 2010

  1. ashbb

    Edited Rakefile to use `libiconv2.dll`. You can get all dependencies …

    authored April 03, 2010

Mar 31, 2010

  1. ashbb

    Oops, fixed a typo.

    authored April 01, 2010
  2. ashbb

    Forgot to copy `readline5.dll` to under shoes/dist directory. Now fixed.

    authored March 31, 2010

Mar 21, 2010

  1. ashbb

    Deleted png12 to use png14 in deps_cairo_1.8.10.

    authored March 22, 2010
  2. ashbb

    Added one line to copy cairo 1.8.10 dependencies.

    authored March 22, 2010

Feb 08, 2010

  1. ashbb

    Revised Rakefile to solve the zlib issue i5m showed me in the Shoooes…

    authored February 09, 2010

Jan 28, 2010

  1. ashbb

    To omit Windows console window, add `-mwindows` option.

    authored January 28, 2010

Jan 27, 2010

  1. ashbb

    To show Shoes mini icon on the Shoes window and use Windows XP style.

    authored January 27, 2010

Jan 23, 2010

  1. ashbb

    Merge branch 'master' of ender672/shoes (commit b68487f) into work

    Resolved the following conflicts:
    	req/sqlite3/ext/sqlite3_api/sqlite3_api_wrap.c
    	shoes/config.h
    	shoes/http/windownload.c
    	shoes/native/windows.c
    authored January 23, 2010

Dec 23, 2009

  1. ashbb

    Stop copying non-dll files under deps/ruby/bin directory.

    authored December 23, 2009
  2. ashbb

    To use Mechanize with Shoes for Windows.

    *Note:* Need to use deps-win32-1.9.1-p376-091223.zip or later.
    
    Download from http://www.rin-shun.com/shoes/index.html
    authored December 23, 2009

Dec 11, 2009

  1. ashbb

    Updated ruby from 1.9.1p243 to 1.9.1p376. Rebuilt zlib1.dll with VC9.

    To require zlib, add one line to Rakefile.
    
    - Copy msvcrt-ruby191.dll and zlib1.dll under C:\ruby\bin to deps/ruby/bin
    - Copy all files under C:\ruby\include to deps/ruby/include
    - Copy all files under C:\ruby\lib to deps/ruby/lib
    - Copy all files under C:\ruby\man to deps/ruby/man
    
    - Delete deps/pango/bin/zlib1.dll
    authored December 12, 2009

Sep 23, 2009

  1. ashbb

    Modified a little bit for Windows: Changed compile option /ML to /MT …

    …for VC9. Changed msvcrt-ruby18.lib to msvcrt-ruby191.lib for using Ruby 1.9.1. Added two lib-pathes to MSVC_CFLAGS for using Ruby 1.9.1.
    authored September 23, 2009
Something went wrong with that request. Please try again.